
  





















    
    
        <!DOCTYPE html>
        <html lang="en">
        <head>
<base href="https://www.postregister.com/content/tncms/live/" />
<meta name="keywords" content="team, skyline, sport, baseball, lead, blackfoot, dax whitney, standing, staff" />
<meta name="news_keywords" content="team, skyline, sport, baseball, lead, blackfoot, dax whitney, standing, staff" />
<meta name="description" content="BLACKFOOT &ndash; It was supposed to be the middle game of a three-game set between the top two teams in the 4A division of the High Country Conference baseball standings." />
<meta name="author" content="By FRED DAVIS fdavis@bcchron.com" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<meta name="apple-mobile-web-app-capable" content="yes" />
<meta name="apple-mobile-web-app-status-bar-style" content="black-translucent" />
<meta name="apple-itunes-app" content="app-id=1433614457" />
<meta name="google-play-app" content="app-id=com.postregister.android" />
<meta name="googlebot" content="noarchive" />
<meta name="google-site-verification" content="Vnz4Ag2L2MW4aw4NqLGa-X1oPKUcDtRbNAiTb6fJMXY" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.postregister.com/chronicle/sports/grizzlies-outlast-broncos-in-hcc-slugfest/article_5cbf7829-f2cc-573c-bd42-8ed8787f5b51.html" />
<meta property="og:image" content="https://bloximages.chicago2.vip.townnews.com/postregister.com/content/tncms/assets/v3/editorial/6/2e/62e25782-f7c0-5492-907b-1329b099e73e/6078ccf2c539f.image.jpg?resize=945%2C630" />
<meta property="og:image:width" content="945" />
<meta property="og:image:height" content="630" />
<meta property="og:title" content="Grizzlies outlast Broncos in HCC slugfest" />
<meta property="og:description" content="BLACKFOOT &ndash; It was supposed to be the middle game of a three-game set between the top two teams in the 4A division of the High Country Conference baseball standings." />
<meta property="og:site_name" content="Post Register" />
<meta property="og:section" content="Sports" />
<meta property="fb:app_id" content="2959550254137794" />
<meta property="article:publisher" content="https://www.facebook.com/postregister/" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@thepostregister" />
<meta name="twitter:image:alt" content="Grizzlies outlast Broncos" />
<meta property="tncms:subs" content="2.0" />
<meta name="twt-site-id" content="0000016c674d34ee_905a743" />
<meta name="twt-article-id" content="5cbf7829-f2cc-573c-bd42-8ed8787f5b51" />
<meta name="twt-author-name" content="By FRED DAVIS fdavis@bcchron.com" />
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/postregister.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/styles/bootstrap.min.44f4ed00052aeaf66307fd409db0d101.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/postregister.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/styles/layout.88630b645c9697f0c3abcfa274bd39d5.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/postregister.com/shared-content/art/tncms/templates/libraries/flex/components/themes/resources/styles/theme-basic.0740431ec2aa31f2e7d813ea5c660a8d.css"/>
<link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Open+Sans:400,400i,700,700i|Raleway:700,700i,900,900i|Crimson+Text:400,400i,700,700i"/>
<link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Oswald:300,400"/>
<link rel="stylesheet" href="https://bloximages.chicago2.vip.townnews.com/postregister.com/content/tncms/live/libraries/flex/components/site/resources/styles/site.css?_dc=1613498295"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/postregister.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/styles/flex-utility-promo-designer.59905c960650c756bd917d9e081675c9.css"/>
<style>/*<![CDATA[*/ #user-controls-1603199 .user-controls .dropdown-menu > li > a { padding: 5px 20px; } #user-controls-1603199 .tn-user-screenname, #user-controls-1603199 .large-user-controls .user-welcome { padding: 0 5px; max-width: 75px; text-overflow: ellipsis; white-space: nowrap; overflow: hidden; } #user-controls-1603199 .large-user-controls .user-welcome { padding:0; max-width: 100%; font-weight: bold; } #user-controls-1603199 .dropdown-signup { font-size: 12px; } #user-controls-1603199 .large-user-controls .tn-user-screenname { padding: 0; } #user-controls-1603199 .large-user-avatar { margin-right: 10px; } #user-controls-1603199 .large-user-controls { font-size: 12px; } #user-controls-1603199 .logout-btn { cursor: pointer; } #user-controls-1603199 .user-welcome { color: #ffffff; } #user-controls-1603199 .login-btn { color: #fff!important; } #weather-1590517 .list-unstyled { margin: 0; } #weather-1590517 span { display: block; } #weather-1590517 .forecast-link a { padding: 8px; margin-top: -10px; } #weather-1590517 .icon { position: relative; } #weather-1590517 .icon .tnt-svg { position: relative; font-size: 52px; margin-right: 5px; margin-top: -8px; } #weather-1590517 .temp { font-size: 24px; line-height: 24px; margin-top: 4px; font-weight: bold; } #weather-1590517 .cond { opacity: 0.7; } #weather-1590517 .current-conditions { float: left; height: 48px; } #weather-1590517 .dropdown-toggle { color: ; display: block; } #weather-1590517.inverted .dropdown-toggle { color: #333; display: block; } #block-1655890 .search-spinner { position: absolute; } #block-1655890 .input-group-btn:last-child > .btn, .input-group-btn:last-child > .btn-group { margin-left: 0; } #site-search-1655890-dropdown .dropdown-menu { padding: 15px; width: 400px; font-weight: normal; } @media screen and (max-width: 991px) { #site-search-1655890-dropdown .dropdown-toggle { display: none; } #main-navigation .navbar-left { clear: both; } #site-search-1655890-dropdown .pull-right { float: none!important; } #site-search-1655890-dropdown .dropdown-menu { display: block; position: static; float: none; width: auto; margin-top: 0; background-color: transparent; border: 0; box-shadow: none; border-radius: 0; border-bottom: 1px solid rgba(0,0,0,0.1); } } #ad-1609241 { min-height: 1px; min-width: 1px; } #block-1830406 .card-panel { border: 5px solid; } #block-1830406 .panel { box-shadow: 10px 10px 10px -10px rgba(0,0,0,0.2); } #block-1830406 .card-panel { border-color: #ccc; } #block-1830406 .promo-designer { background-repeat: no-repeat; background-size: cover; } #block-1830406 .card-panel.panel { background-repeat: no-repeat; background-size: cover; background-position: center; }#block-1830406 .promo-designer, #block-1830406 .card-panel.panel { background-image: url(https://bloximages.chicago2.vip.townnews.com/postregister.com/content/tncms/custom/image/d524b17e-711e-11ea-b995-2b132648471f.jpg) } #block-1830406.block { margin-bottom: 0 !important; } #ad-1609232 { min-height: 90px; min-width: 728px; } #ad-1609239 { min-height: 50px; min-width: 320px; } #tncms-block-1934520 .tnt-prop-img { max-width: 300px; } #ad-1609233 { min-height: 600px; min-width: 300px; } #ad-1609237 { min-height: 250px; min-width: 300px; } #block-1600885 .card.summary { border: 0; padding: 0; margin: 0; } #block-1600885 .card-panel { background-color: #ffffff; border-color: rgba(0,0,0,.08); } #tncms-block-1646372 .tnt-prop-img { max-width: 360px; } #ad-1609236 { min-height: 250px; min-width: 300px; } #ad-1609235 { min-height: 250px; min-width: 300px; } #ad-1609238 { min-height: 90px; min-width: 728px; } #ad-1609240 { min-height: 50px; min-width: 320px; } /*]]>*/</style>
<script type="text/javascript">(function(){var tnsrc=window.location.hash.match(/[&#]tncms-source=([^&]+)/);var dl = window.dataLayer = window.dataLayer || [];dl.push({"townnews":{"product":{"software":"BLOX","version":"1.57.0"}},"tncms":{"template":{"version":"3.155.0"},"page":{"grid":"pattern","style":"default","path":"\/chronicle\/sports","syndicated":"false","reaction":"false","app":"editorial","theme":"flex","skin":"flex-editorial","http_status":200},"subscription":{"required":"true"},"asset":{"author":"By FRED DAVIS\nfdavis@bcchron.com","id":"5cbf7829-f2cc-573c-bd42-8ed8787f5b51","app":"editorial"},"infinity_scroll":{"display":"summary_sticky_siderail","order":"next"},"vendor":{"outbrain":"disabled","taboola":""},"system":{"render_time":243},"client":{"is_bot":"no","is_gdpr":"no"}}});if (tnsrc && tnsrc[1]) {dl.push({'tncms.campaign.internal_source': tnsrc[1]});}window.addEventListener("DOMContentLoaded", function(oEvent) {var oTest = document.createElement('div');oTest.innerHTML = '&nbsp;';oTest.className = 'adsbox';document.body.appendChild(oTest);var nTimeoutID = window.setTimeout(function() {if (oTest.offsetHeight === 0) {dl.push({'event': 'tncms.ad.blocked'});}document.body.removeChild(oTest);window.clearTimeout(nTimeoutID);}, 100);});var nWidth=Math.max(document.documentElement.clientWidth, window.innerWidth || 0),aBPs=[[300,"Extra small: Most smartphones."],[768,"Small: Tablet devices."],[992,"Medium: Laptops & landscape tablets."],[1200,"Large: Desktop computers."]],i,c,aThisBP,aBP;for(i=0,c=aBPs.length;i<c;i++){aThisBP=aBPs[i];if(aBP===undefined||aThisBP[0]<=nWidth){aBP=aThisBP;}}if(aBP!==undefined){dl.push({'tncms.client.breakpoint':aBP[1]});}(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'tncms.start':new Date().getTime(),event:'tncms.start'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-PDQV3N');})();</script>
<script type="text/javascript">(function(){var tnsrc=window.location.hash.match(/[&#]tncms-source=([^&]+)/);var dl = window.dataLayer = window.dataLayer || [];dl.push({"townnews":{"product":{"software":"BLOX","version":"1.57.0"}},"tncms":{"template":{"version":"3.155.0"},"page":{"grid":"pattern","style":"default","path":"\/chronicle\/sports","syndicated":"false","reaction":"false","app":"editorial","theme":"flex","skin":"flex-editorial","http_status":200},"subscription":{"required":"true"},"asset":{"author":"By FRED DAVIS\nfdavis@bcchron.com","id":"5cbf7829-f2cc-573c-bd42-8ed8787f5b51","app":"editorial"},"infinity_scroll":{"display":"summary_sticky_siderail","order":"next"},"vendor":{"outbrain":"disabled","taboola":""},"system":{"render_time":243},"client":{"is_bot":"no","is_gdpr":"no"}}});if (tnsrc && tnsrc[1]) {dl.push({'tncms.campaign.internal_source': tnsrc[1]});}window.addEventListener("DOMContentLoaded", function(oEvent) {var oTest = document.createElement('div');oTest.innerHTML = '&nbsp;';oTest.className = 'adsbox';document.body.appendChild(oTest);var nTimeoutID = window.setTimeout(function() {if (oTest.offsetHeight === 0) {dl.push({'event': 'tncms.ad.blocked'});}document.body.removeChild(oTest);window.clearTimeout(nTimeoutID);}, 100);});var nWidth=Math.max(document.documentElement.clientWidth, window.innerWidth || 0),aBPs=[[300,"Extra small: Most smartphones."],[768,"Small: Tablet devices."],[992,"Medium: Laptops & landscape tablets."],[1200,"Large: Desktop computers."]],i,c,aThisBP,aBP;for(i=0,c=aBPs.length;i<c;i++){aThisBP=aBPs[i];if(aBP===undefined||aThisBP[0]<=nWidth){aBP=aThisBP;}}if(aBP!==undefined){dl.push({'tncms.client.breakpoint':aBP[1]});}(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-5WM99PS');})();</script>
<script src="/shared-content/art/tncms/user/user.js"></script>
<script src="/shared-content/art/tncms/tracking.js"></script>
<script src="/shared-content/art/tncms/subscription.js"></script>
<script>/*<![CDATA[*/ TNCMS.Subscription.initialize({"service_id": "7468,7529", "prefix": ""}); /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/postregister.com/shared-content/art/tncms/templates/libraries/flex/components/jquery/resources/scripts/jquery.min.6edb5af3e93b0a377ec925c5f1c6ddde.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/postregister.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/scripts/bootstrap.min.d457560d3dfbf1d56a225eb99d7b0702.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/postregister.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/common.5ee3960b4d37bc106988fa535b393865.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/postregister.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.1477faac295a3745e4796d2263e75f11.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/postregister.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/application.93d1db0a57d520951552a1dcd8fd9aeb.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/postregister.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.navigation.accessibility.3184e9304073379bbe4e2c6500858bb1.js"></script>
<script src="https://polyfill.io/v3/polyfill.min.js?features=default,fetch,IntersectionObserver,NodeList.prototype.@@iterator,Element.prototype.classList|gated" nomodule="nomodule"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/postregister.com/shared-content/art/tncms/templates/libraries/flex/components/subscription/resources/scripts/tnt.access.status.828de94349981272665c0fb0107f3e49.js"></script>
<script>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</script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/postregister.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/scripts/user-controls.578df3df79d812af55ab13bae47f9857.js"></script>
<script async="async" src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>/*<![CDATA[*/ window.googletag = window.googletag || {cmd: []};
    window.gptAdSlots = window.gptAdSlots || [];

    window.__tnt = window.__tnt || {};
    __tnt.ads = __tnt.ads || {};
    __tnt.ads.dfp = __tnt.ads.dfp || {};

    __tnt.ads.dfp.targeting = __tnt.ads.dfp.targeting || {};
    __tnt.ads.dfp.targeting.k = ["team","skyline","sport","baseball","lead","blackfoot","dax whitney","standing","staff"];

    __tnt.ads.dfp.targeting.page = ["asset","article","app-editorial"];
    __tnt.ads.dfp.templates = __tnt.ads.dfp.templates || {};
    __tnt.ads.dfp.templates = {
        interstitial:"https:\/\/bloximages.chicago2.vip.townnews.com\/postregister.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/interstitial.7047e23fde50ef7dc7625903de95abec.js",
        nativeArticle:"https:\/\/bloximages.chicago2.vip.townnews.com\/postregister.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/native-article.9b3cd3bb8591bed71346f4fe429b96dc.js",
        pageCurl:"https:\/\/bloximages.chicago2.vip.townnews.com\/postregister.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/page-curl.ca0c1a7372c29272ef1ccf504ced01a9.js",
        parallax:"https:\/\/bloximages.chicago2.vip.townnews.com\/postregister.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/parallax.0ce32932f3b4125f930bea8d431f8f03.js",
        paw:"https:\/\/bloximages.chicago2.vip.townnews.com\/postregister.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/paw.f2c3f73025b675e671c97fb411b2228d.js",
        pencil:"https:\/\/bloximages.chicago2.vip.townnews.com\/postregister.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/pencil.8cf6eeafd9d2d9371b611e86c7c099c1.js",
        reveal:"https:\/\/bloximages.chicago2.vip.townnews.com\/postregister.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/reveal.e5d561a6b71aa2730a07fa90f5f4f6d6.js",
        stickyAnchor:"https:\/\/bloximages.chicago2.vip.townnews.com\/postregister.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/sticky-anchor.6dc181cbc3d60e2a1892d05998349ef6.js",
        video:"https:\/\/bloximages.chicago2.vip.townnews.com\/postregister.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/video-inline.9b0997ab77d1d69707d283848faeacdd.js",
        wallpaper:"https:\/\/bloximages.chicago2.vip.townnews.com\/postregister.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/wallpaper.dc1c1bace62343a130be3589fe0846f9.js"
    }; /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/94837440/postregister/chronicle/sports';
            
                gptAdSlots['ad-1609241'] = googletag.defineSlot(adUnit, [1,1], 'ad-1609241').setCollapseEmptyDiv(true).addService(googletag.pubads());
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ window.promo_design_config || (window.promo_design_config = []); window.promo_design_config.push({"button_size":"btn-lg","button_style":"danger","button_text":"Contribute","button_url":"\/contribute","card_shape":"rounded_rectangle","content_text":"Now, more than ever, the world needs trustworthy reporting\u2014but good journalism isn\u2019t free. Please support us by making a contribution.","content_text_color":"light","content_text_shadow":"enabled","display_again":"24","display_timer":"1","display_triggers":"visitor_enter","headline_shadow":"enabled","headline_size":"large","headline_text":"Support local journalism","headline_text_color":"light","image":{},"image_display":"background","overlay_action":"centered","utm_campaign_name":"contribute","heading_tag":"h3","heading_bg_color":"","heading_text_color":"inherit","note":"","links_position":"top","display_width":"region","card_shadow":"enabled","bg_color":"","outline_color":"#ccc","border_width":"5","sticker_shape":"disabled","sticker_color":"#333333","sticker_icon":"exclamation","sticker_icon_color":"white","lead_in":"","lead_text_color":"dark","lead_text_shadow":"disabled","info_text":"","info_text_color":"dark","info_text_shadow":"disabled","enable_email":"","require_user_account":"","signup_lists_only":"","list_ids":"","email_text_color":"dark","email_text_shadow":"disabled","email_button_style":"default","sign_up_text":"Sign up","manage_button_text":"Manage your lists","utm_tracking":"0","utm_source":"blox","utm_medium":"utility_promo_designer","utm_campaign":"pop_up","utm_campaign_content":"utility_promo_designer","show_audience":"","hide_audience":"","block_id":"1830406"}); /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/94837440/postregister/chronicle/sports';
            var mapping = googletag.sizeMapping().addSize([320, 0], []).addSize([768, 0], []).addSize([992, 0], [728, 90]).addSize([1200, 0], [728, 90]).build();
                gptAdSlots['ad-1609232'] = googletag.defineSlot(adUnit, [728, 90], 'ad-1609232').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-1609232'].setTargeting('pos', ['png_top']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/94837440/postregister/chronicle/sports';
            var mapping = googletag.sizeMapping().addSize([320, 0], [320,50]).addSize([768, 0], [320,50]).addSize([992, 0], []).addSize([1200, 0], []).build();
                gptAdSlots['ad-1609239'] = googletag.defineSlot(adUnit, [320,50], 'ad-1609239').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-1609239'].setTargeting('pos', ['png_top']);
    });
 /*]]>*/</script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/postregister.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/sms-link.8eefede3265fd6c6de07bc0cb5f3f779.js"></script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/postregister.com/shared-content/art/tncms/templates/libraries/flex/components/asset/resources/scripts/tnt.nextPrev.f1660ccf5d097410b8b72737d216878c.js"></script>
<script async="async" src="https://app.worldtable.co/the-world-table.js"></script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/94837440/postregister/chronicle/sports';
            
                gptAdSlots['fixed-big-ad-top-asset'] = googletag.defineSlot(adUnit, [300,250], 'fixed-big-ad-top-asset').setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['fixed-big-ad-top-asset'].setTargeting('pos', ['fixed-big-ad-top-asset','atf']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/94837440/postregister/chronicle/sports';
            
                gptAdSlots['fixed-big-ad-middle-asset'] = googletag.defineSlot(adUnit, [300,250], 'fixed-big-ad-middle-asset').setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['fixed-big-ad-middle-asset'].setTargeting('pos', ['fixed-big-ad-middle-asset','stf']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/94837440/postregister/chronicle/sports';
            
                gptAdSlots['fixed-big-ad-bottom-asset'] = googletag.defineSlot(adUnit, [300,250], 'fixed-big-ad-bottom-asset').setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['fixed-big-ad-bottom-asset'].setTargeting('pos', ['fixed-big-ad-bottom-asset','btf']);
    });
 /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/postregister.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/jquery.waypoints.1115c65bd62165d952fac7c1b6918b2a.js"></script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/94837440/postregister/chronicle/sports';
            var mapping = googletag.sizeMapping().addSize([320, 0], []).addSize([768, 0], []).addSize([992, 0], [300, 600]).addSize([1200, 0], [300, 600]).build();
                gptAdSlots['ad-1609233'] = googletag.defineSlot(adUnit, [300, 600], 'ad-1609233').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-1609233'].setTargeting('pos', ['png_top']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/94837440/postregister/chronicle/sports';
            var mapping = googletag.sizeMapping().addSize([320, 0], [300, 250]).addSize([768, 0], [300, 250]).addSize([992, 0], []).addSize([1200, 0], []).build();
                gptAdSlots['ad-1609237'] = googletag.defineSlot(adUnit, [300, 250], 'ad-1609237').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-1609237'].setTargeting('pos', ['png_top']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/94837440/postregister/chronicle/sports';
            
                gptAdSlots['ad-1609236'] = googletag.defineSlot(adUnit, [300, 250], 'ad-1609236').setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-1609236'].setTargeting('pos', ['png_top']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/94837440/postregister/chronicle/sports';
            
                gptAdSlots['ad-1609235'] = googletag.defineSlot(adUnit, [300, 250], 'ad-1609235').setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-1609235'].setTargeting('pos', ['png_bottom']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/94837440/postregister/chronicle/sports';
            var mapping = googletag.sizeMapping().addSize([320, 0], []).addSize([768, 0], []).addSize([992, 0], [728, 90]).addSize([1200, 0], [728, 90]).build();
                gptAdSlots['ad-1609238'] = googletag.defineSlot(adUnit, [728, 90], 'ad-1609238').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-1609238'].setTargeting('pos', ['png_bottom']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/94837440/postregister/chronicle/sports';
            var mapping = googletag.sizeMapping().addSize([320, 0], [320,50]).addSize([768, 0], [320,50]).addSize([992, 0], []).addSize([1200, 0], []).build();
                gptAdSlots['ad-1609240'] = googletag.defineSlot(adUnit, [320,50], 'ad-1609240').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-1609240'].setTargeting('pos', ['png_bottom']);
    });
 /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/postregister.com/shared-content/art/tncms/templates/libraries/flex/components/ads/resources/scripts/tnt.ads.adverts.66a3812a7b5c12fde8cd998fd691ad7d.js"></script>
<script>/*<![CDATA[*/ __tnt.recentFive = {
    /*
     * Gets the data stored in 'tnt:recent:five'
     * Returns Array
     */
        get:function(){
            if(window.localStorage && localStorage.getItem('tnt:recent:five')!=null){
                try{ return JSON.parse(localStorage.getItem('tnt:recent:five')); } catch {}
            }

            return [];
        },

    /*
     * Sets the 'tnt:recent:five' localStorage item
     * Returns boolean
     */
        set:function(data){
            if(window.localStorage){
                try{ 
                    localStorage.setItem('tnt:recent:five', JSON.stringify(data));
                    return true;
                } catch {}
            }

            return false;
        },

    /*
     * Adds the most recent item, prunes any duplicates, and trims the array down to 5 items
     * Returns Array on success, false on fail 
     */
        add:function(asset){
            var assets = __tnt.recentFive.get();
            assets.unshift(asset);

            if(assets.length > 1){
                assets = assets.filter(function(item, index, a){ return a.indexOf(item) == index });

                while(assets.length>5){
                    assets.shift();
                }
            }

            if(__tnt.recentFive.set(assets)){ return assets; }
            return false;
        }
    }; /*]]>*/</script>
<script>/*<![CDATA[*/ 

    googletag.cmd.push(function() {
        googletag.pubads().setTargeting('browser', __tnt.client.browser.name);
        if (__tnt.ads.dfp.targeting) {
            for (var k in __tnt.ads.dfp.targeting) {
                if (__tnt.ads.dfp.targeting.hasOwnProperty(k)) {
                    googletag.pubads().setTargeting(k,__tnt.ads.dfp.targeting[k]);
                }
            }
        }

        googletag.pubads().enableSingleRequest();
        googletag.enableServices();
    });
 /*]]>*/</script>

            
            <title>Grizzlies outlast Broncos in HCC slugfest | Sports | postregister.com</title>
            
    <style>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</style> <link rel="shortcut icon" href="https://bloximages.chicago2.vip.townnews.com/postregister.com/content/tncms/live/libraries/flex/components/site/resources/images/logos/bcc-logo-fav.png"> <style> /* Rules for premium icon */ .headline-list .premium-asset-icon { margin-left: 0; margin-right: 0; } </style> <!-- site.css.inc.utl has been included. --> <!-- NOTE: anything in an include file, outside of UTL tags , will be output on the page --> <style> /* Place site-wide CSS here */ /* Support Local Journalism - Christine */ .tnc-overlay .promo-design button.close {opacity: 1; color:#FFFFFF;} </style>
    
        <link rel="apple-touch-icon" href="https://bloximages.chicago2.vip.townnews.com/postregister.com/content/tncms/custom/image/e03149cc-95b7-11e8-82af-47f108f2db28.png?resize=180%2C180" />
    
        <link rel="amphtml" href="https://www.postregister.com/chronicle/sports/grizzlies-outlast-broncos-in-hcc-slugfest/article_5cbf7829-f2cc-573c-bd42-8ed8787f5b51.amp.html" />
    
        <link rel="preconnect" href="//www.google.com">
    
        <link rel="preconnect" href="//adservice.google.com">
    
        <link rel="preconnect" href="//securepubads.g.doubleclick.net">
    
        <link rel="preconnect" href="//stats.g.doubleclick.net">
    
        <link rel="preconnect" href="//tpc.googlesyndication.com">
    
        <link rel="preconnect" href="//pagead2.googlesyndication.com">
    
        <link rel="preconnect" href="//www.googletagmanager.com">
    
        <link rel="preconnect" href="//www.google-analytics.com">
    
        <link rel="preconnect" href="//app.worldtable.co">
    <link rel="alternate" type="application/rss+xml" title="Grizzlies outlast Broncos in HCC slugfest | Sports | postregister.com" href="http://www.postregister.com/search/?f=rss&amp;t=article&amp;c=chronicle/sports&amp;l=50&amp;s=start_time&amp;sd=desc" />
    <link rel="canonical" href="https://www.postregister.com/chronicle/sports/grizzlies-outlast-broncos-in-hcc-slugfest/article_5cbf7829-f2cc-573c-bd42-8ed8787f5b51.html" />
            <script defer src="https://bloximages.chicago2.vip.townnews.com/postregister.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/fontawesome.edd147e4c2830f416874012247117438.js"></script>
            <!-- page app is editorial url is /chronicle/sports/grizzlies-outlast-broncos-in-hcc-slugfest/article_5cbf7829-f2cc-573c-bd42-8ed8787f5b51.html--><!-- loading site js --><script type='text/javascript' src='https://s.ntv.io/serve/load.js' async></script>
    
    
        </head>
        <body class="fixed-scroll-nav app-editorial grid-pattern blox-asset uuid-5cbf7829-f2cc-573c-bd42-8ed8787f5b51  section-chronicle section-sports type-article infinity-summary-sticky-siderail" data-path="/chronicle/sports">
	<script type='text/javascript' src='/shared-content/art/stats/common/tracker.js'></script>
	<script type='text/javascript'>
	<!--
	if (typeof(TNStats_Tracker) !== 'undefined' && typeof(TNTracker) === 'undefined') { TNTracker = new TNStats_Tracker('www.postregister.com'); TNTracker.trackPageView(); }
	// -->
	</script>
	<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PDQV3N&amp;townnews.product.software=BLOX&amp;townnews.product.version=1.57.0&amp;tncms.template.version=3.155.0&amp;tncms.page.grid=pattern&amp;tncms.page.style=default&amp;tncms.page.path=%2Fchronicle%2Fsports&amp;tncms.page.syndicated=false&amp;tncms.page.reaction=false&amp;tncms.page.app=editorial&amp;tncms.page.theme=flex&amp;tncms.page.skin=flex-editorial&amp;tncms.page.http_status=200&amp;tncms.subscription.required=true&amp;tncms.asset.author=By+FRED+DAVIS%0Afdavis%40bcchron.com&amp;tncms.asset.id=5cbf7829-f2cc-573c-bd42-8ed8787f5b51&amp;tncms.asset.app=editorial&amp;tncms.infinity_scroll.display=summary_sticky_siderail&amp;tncms.infinity_scroll.order=next&amp;tncms.vendor.outbrain=disabled&amp;tncms.vendor.taboola=&amp;tncms.system.render_time=243&amp;tncms.client.is_bot=no&amp;tncms.client.is_gdpr=no&amp;tncms.client.noscript=yes" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-5WM99PS&amp;townnews.product.software=BLOX&amp;townnews.product.version=1.57.0&amp;tncms.template.version=3.155.0&amp;tncms.page.grid=pattern&amp;tncms.page.style=default&amp;tncms.page.path=%2Fchronicle%2Fsports&amp;tncms.page.syndicated=false&amp;tncms.page.reaction=false&amp;tncms.page.app=editorial&amp;tncms.page.theme=flex&amp;tncms.page.skin=flex-editorial&amp;tncms.page.http_status=200&amp;tncms.subscription.required=true&amp;tncms.asset.author=By+FRED+DAVIS%0Afdavis%40bcchron.com&amp;tncms.asset.id=5cbf7829-f2cc-573c-bd42-8ed8787f5b51&amp;tncms.asset.app=editorial&amp;tncms.infinity_scroll.display=summary_sticky_siderail&amp;tncms.infinity_scroll.order=next&amp;tncms.vendor.outbrain=disabled&amp;tncms.vendor.taboola=&amp;tncms.system.render_time=243&amp;tncms.client.is_bot=no&amp;tncms.client.is_gdpr=no&amp;tncms.client.noscript=yes" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript><div id="fb-root"></div>
        
        
        
        
        <script>
            document.addEventListener("DOMContentLoaded", function(event) {
                __tnt.metering.access.d.push(function(){
                    //DMP logging
                    if(window._cc){
                        __tnt.log("Logging DMP data")
                        var paywallDmpData = 'Paywall : Viewed Paywall';
                        // Call to cms.dmp.js_behavior_action is here
                        
                    }
                });
            });
        </script>
    

    <div id="template-metering" data-message-mode="login">
    <template class="template meter subscription">
        <div class="meter message" data-message="newzware regissub subscription wall">
        <div class="wall panel panel-default">
            <div class="panel-body">
                <h4 class="meter-heading media-heading">
                    Thank you for reading!
                </h4>

                <p>Please purchase a subscription to read our premium content. If you have a subscription, please log in or sign up for an account on our website to continue.
</p>

                <div class="not-logged-in col-xs-12">
                    <div class="col-xs-6">
                        
    <a  class="btn btn-default btn-block" href="/tncms/auth/begin/?provider=Newzware&return=https%3A%2F%2Fwww.postregister.com%2Fchronicle%2Fsports%2Fgrizzlies-outlast-broncos-in-hcc-slugfest%2Farticle_5cbf7829-f2cc-573c-bd42-8ed8787f5b51.html">Sign Up</a>
                    </div>
                    <div class="col-xs-6">
                        
    <a class="btn btn-primary btn-block" href="https://www.postregister.com/users/login/?referer_url=https%3A%2F%2Fwww.postregister.com%2Fchronicle%2Fsports%2Fgrizzlies-outlast-broncos-in-hcc-slugfest%2Farticle_5cbf7829-f2cc-573c-bd42-8ed8787f5b51.html">Log In</a>
                    </div>
                </div>
                
            </div>
        </div>
        </div>

</template>
    
    <template class="template meter registration">
        
    <div class="meter message wall panel panel-default" data-message="blox registration wall">
        <div class="panel-body">
            <h4 class="meter-heading media-heading">
                Thank you for reading!

            </h4>
            <p>Please <span class="not-logged-in">log in, or sign up for a new account</span> to continue reading.</p>

            <div class="col-xs-12">
                <div class="row not-logged-in">
                
                    <div class="col-xs-6">
                        
    <a  class="btn btn-default btn-block" href="/tncms/auth/begin/?provider=Newzware&return=https%3A%2F%2Fwww.postregister.com%2Fchronicle%2Fsports%2Fgrizzlies-outlast-broncos-in-hcc-slugfest%2Farticle_5cbf7829-f2cc-573c-bd42-8ed8787f5b51.html">Sign Up</a>
                    </div>
                    <div class="col-xs-6">
                        
    <a class="btn btn-primary btn-block" href="https://www.postregister.com/users/login/?referer_url=https%3A%2F%2Fwww.postregister.com%2Fchronicle%2Fsports%2Fgrizzlies-outlast-broncos-in-hcc-slugfest%2Farticle_5cbf7829-f2cc-573c-bd42-8ed8787f5b51.html">Log In</a>
                    </div>
                </div>
                
                <div class="row logged-in">
                    <a class="btn btn-default" href="https://www.postregister.com/users/admin/service/purchase/?referer_url=https%253A%252F%252Fwww.postregister.com%252Fchronicle%252Fsports%252Fgrizzlies-outlast-broncos-in-hcc-slugfest%252Farticle_5cbf7829-f2cc-573c-bd42-8ed8787f5b51.html">Purchase a Subscription
</a>
                </div>
            </div>
        </div>
    </div>
</template>
    
    <template class="template meter referred">
        <div class="meter notification referred alert alert-dismissable alert-info" data-message="blox user referred">
        <button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button>
         
        <p><strong>Thank you for reading!
</strong> We hope that you continue to enjoy our free content.</p>
    </div>
</template>
    
    
    
</div>
<script>
            $(function(){
                var bloxServiceIDs = [];
                var bloxUserServiceIds = [];
                var dataLayer = window.dataLayer || [];

                
                bloxServiceIDs.push(7468);
                
                bloxServiceIDs.push(7529);
                

                if (__tnt.user.services){
                    var bloxUserServiceIDs = __tnt.user.services.replace('%2C',',').split(',');
                }

                // GTM tncms.subscription.paid_access_service_ids
                if(bloxServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'access_service_ids':bloxServiceIDs.toString()}}});
                }

                // GTM tncms.subscrption.user_service_ids
                if(bloxUserServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'user_service_ids':bloxUserServiceIDs.toString()}}});
                }
            });
        </script>
        
        <div id="site-container"><div id="asset-admin-bar" class="asset-edit-bar hidden-print">
                <div class="asset-edit-icon"><i class="fas tnt-lock-open tnt-fw"></i></div>
                <div class="asset-edit-message">You have permission to edit this article.</div>
                <div class="asset-edit-btns">
                    <a class="btn btn-primary btn-sm" target="_blank" rel="noopener" href="https://www.postregister.com/tncms/admin/editorial-asset/?edit=5cbf7829-f2cc-573c-bd42-8ed8787f5b51"><i class="fas tnt-pencil-alt tnt-fw"></i> Edit</a>
                    <button class="asset-edit-close btn btn-link btn-sm"><i class="fas tnt-times"></i><span class="sr-only">Close</span></button>
                </div>
            </div>
        
        
        
    
        
            
                <aside class="hidden-print offcanvas-drawer offcanvas-drawer-left ">
                    <div id="tncms-region-mobile-nav-top-left-region" class="tncms-region "><div id="tncms-block-1590512" class="tncms-block"><div id="site-brand-mark-1590512" class="tncms-block site-brand-mark">
        <section class="block emphasis-h3">
            <div class="block">
                <a href="/chronicle"><img class="img-responsive" alt="Bingham County" src="https://bloximages.chicago2.vip.townnews.com/postregister.com/content/tncms/live/libraries/flex/components/site/resources/images/logos/bcc-logo-btn.png?_dc=1550768991"></a>
                        </div>
        </section>
    </div>
    <div id="site-follow-us-1590512" class="tncms-block site-follow-us">
        <div class="default">
            <section class="block emphasis-h3">
                <ul class="list-inline">
                    <li><a class="btn btn-xs btn-link fb" href="https://www.facebook.com/BinghamNewsChronicle" target="_blank" title="Facebook"><span class="fab tnt-facebook-f"></span></a></li></ul>
            </section>
        </div>
        <div class="clearfix"></div>
    </div></div><div id="tncms-block-1603199" class="tncms-block apg-js-mobile-login-tweak"><div id="user-controls-1603199" class="user-controls show-onload clearfix pull-right"><div class="not-logged-in">
        <ul class="list-inline"><li><a href="/tncms/auth/begin/?provider=Newzware&return=https%3A%2F%2Fwww.postregister.com%2Fchronicle%2Fsports%2Fgrizzlies-outlast-broncos-in-hcc-slugfest%2Farticle_5cbf7829-f2cc-573c-bd42-8ed8787f5b51.html" class="btn btn-link btn-sm user-control-link" rel="nofollow">Sign Up</a></li><li>
                    <a href="https://www.postregister.com/users/login/?referer_url=https%3A%2F%2Fwww.postregister.com%2Fchronicle%2Fsports%2Fgrizzlies-outlast-broncos-in-hcc-slugfest%2Farticle_5cbf7829-f2cc-573c-bd42-8ed8787f5b51.html" class="btn btn-primary btn-sm login-btn user-control-link" rel="nofollow">
                        Log In
                    </a></li>
        </ul>
    </div>

    <div class="logged-in">
        
        
            <div class="hide show-offcanvas">
                <ul class="list-inline">
                    <li><a href="https://www.postregister.com/users/admin/" class="btn btn-primary btn-sm login-btn user-control-link">Dashboard</a></li>
                    <li> <a class="btn btn-link btn-sm user-control-link" onclick="document.getElementById('user-logout-form-1603199').submit(); return false;" rel="nofollow"> Logout</a></li>
                </ul>
            </div>
        
        <ul class="hide-offcanvas list-inline">
            <li class="dropdown pull-right">
                
                <div class="dropdown-toggle btn btn-link btn-sm user-dropdown" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250"><div class="tn-user-avatar pull-left"><!-- user avatar --></div><span class="tn-user-screenname pull-left"></span><b class="caret user-control-link"></b>
                </div>
                <ul class="dropdown-menu dropdown-menu-right" role="menu">
                    <li role="presentation" class="dropdown-header">My Account</li>
                    <li role="menuitem"><a href="https://www.postregister.com/users/admin/" rel="nofollow"><i class="fas tnt-tachometer-alt tnt-fw"></i> Dashboard</a></li>
                    <li role="menuitem"><a class="tn-user-profile-url" href="" data-app="https://www.postregister.com/users/"><i class="fas tnt-user tnt-fw"></i> Profile</a></li>
                    <li role="menuitem"><a href="https://www.postregister.com/users/admin/list/" rel="nofollow"><i class="fas tnt-bookmark tnt-fw"></i> Saved items</a></li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem"><a class="logout-btn" onclick="document.getElementById('user-logout-form-1603199').submit(); return false;" rel="nofollow"><i class="fas tnt-power-off tnt-fw"></i> Logout</a></li>
                </ul>
            </li>
        </ul>
    </div>
</div>

<form method="post" action="https://www.postregister.com/users/logout/" id="user-logout-form-1603199"><input type="hidden" name="referer_url" value="https://www.postregister.com/chronicle/sports/grizzlies-outlast-broncos-in-hcc-slugfest/article_5cbf7829-f2cc-573c-bd42-8ed8787f5b51.html"><input type="submit" name="logout" value="Logout" class="hide">
</form></div><div id="tncms-block-1603198" class="tncms-block"><div class="tncms-block site-nav-sections-header">
  <section class="block emphasis-h3"><div class="clearfix">
      <ul class="list-inline block-links pos-top"><li>
          <a class href="/subscribe" target="_blank">
            <span style="color:#ff9900;">Start a subscription today!</span>
          </a>
        </li>
      </ul><div class="drawer-title">
        <div class="drawer-title-inner">
          <h3>Sections</h3>
        </div>
      </div>
    </div>
  </section></div></div></div>
                    <div id="tncms-region-nav-mobile-nav-left" class="tncms-region-nav"><div id="mobile-nav-left_menu" class="panel-group nav navbar-nav" role="tablist" aria-hidden="true"><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/chronicle/news/"  class="nav-link tnt-section-news">News</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/chronicle/coronavirus/"  class="nav-link tnt-section-covid-19">COVID-19</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/chronicle/sports/"  class="nav-link tnt-section-sports">Sports</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/chronicle/opinion/"  class="nav-link tnt-section-opinion">Opinion</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/chronicle/obituaries/"  class="nav-link tnt-section-obituaries">Obituaries</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/chronicle/local_scenes/"  class="nav-link tnt-section-local-scenes">Local Scenes</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-7" data-target="#mobile-nav-left_menu-child-7">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a tabindex="-1" aria-hidden="true" href="/chronicle/milestones/"  class="nav-link tnt-section-milestones">Milestones</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-7" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/chronicle/milestones/anniversaries/"  class="nav-link tnt-section-anniversaries">Anniversaries</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/chronicle/milestones/birthdays/"  class="nav-link tnt-section-birthdays">Birthdays</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/chronicle/milestones/births/"  class="nav-link tnt-section-births">Births</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/chronicle/milestones/engagements/"  class="nav-link tnt-section-engagements">Engagements</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/chronicle/milestones/missions/"  class="nav-link tnt-section-missions">Missions</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/chronicle/milestones/weddings/"  class="nav-link tnt-section-weddings">Weddings</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-8" data-target="#mobile-nav-left_menu-child-8">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a tabindex="-1" aria-hidden="true" href="/chronicle/local-events/"  class="nav-link tnt-section-calendar">Calendar</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-8" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="https://new.evvnt.com/?with_navbar&amp;force_snap_sell&amp;partner=POSTREGISTERN&amp;publisher_url:postregister.com/chronicle#/quick"  target="_blank" rel="noopener" class="nav-link tnt-section-promote-your-event">Promote Your Event</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="https://www.idahostatejournal.com/classifieds/"  target="_blank" rel="noopener" class="nav-link tnt-section-classifieds">Classifieds</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-10" data-target="#mobile-nav-left_menu-child-10">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a tabindex="-1" aria-hidden="true" href="/chronicle/contests/"  class="nav-link tnt-section-contests">Contests</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-10" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="http://binghamcountychronicle.secondstreetapp.com/5000-Spring-Home-Improvement-Sweepstakes/"  target="_blank" rel="noopener" class="nav-link tnt-section-5000-home-improvement-sweepstakes">$5,000 Home Improvement Sweepstakes</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="http://binghamcountychronicle.secondstreetapp.com/Readers-Choice-2021/"  target="_blank" rel="noopener" class="nav-link tnt-section-readers-choice">Readers' Choice</a>
                                </li></ul></div></div></div>
                    
                    <div id="tncms-region-mobile-nav-middle-left-region" class="tncms-region "><div id="tncms-block-1924943" class="tncms-block"><script>
    let buttonWrapper = document.querySelector('.apg-js-mobile-login-tweak .not-logged-in .list-inline');
    //buttonWrapper.firstElementChild.style.display = 'none';

    let subscribeButton = document.createElement("li");
    subscribeButton.innerHTML = `
    <a href='/chronicle/subscribe' class='btn btn-primary btn-sm login-btn user-control-link'
        style='background-color: #FF6600; color: white'
    >
        Subscribe
    
`;
    buttonWrapper.appendChild(subscribeButton);
</script></div><div id="tncms-block-1603135" class="tncms-block"><div class="tncms-region-nav" id="htmlHardcoded-region-nav-mobile-nav-left-middle">
    <div class="panel-group nav navbar-nav" id="mobile-nav-left-middle_menu" role="tablist">
        <div class="panel panel-default">
            <div class="panel-heading" role="tab">
                <div class="panel-title">
                    <a href="/eedition/postregister/"><span class="topbarLink"><i aria-hidden="true" class="fas tnt-newspaper"></i> Read the E-Edition</span></a>
                </div>
            </div>
        </div>
        <div class="panel panel-default">
            <div class="panel-heading" role="tab">
                <div class="panel-title">
                    <a aria-controls="mobile-nav-left-bottom_menu-child-2" aria-expanded="false" class="expand-children collapsed pull-right" data-target="#mobile-nav-left-bottom_menu-child-2" data-toggle="collapse"><i class="fas tnt-chevron-down"></i></a> <a><i aria-hidden="true" class="fas tnt-bullhorn"></i> Make An Announcement</a>
                </div>
            </div>
            <ul class="collapse nav navbar-nav" id="mobile-nav-left-bottom_menu-child-2">
<li>
                    <a href="/site/forms/postregister/pr_anniversary/">Anniversary</a>
                </li>
                <li>
                    <a href="/site/forms/postregister/pr_birth/">Birth</a>
                </li>
                <li>
                    <a href="/site/forms/postregister/pr_birthday/">Birthdays</a>
                </li>
                <li>
<a href="/site/forms/postregister/post_register_eagle_scout/">Eagle Scout</a>
               </li>
               <li>
                    <a href="/site/forms/postregister/pr_missionary/">Missionary</a>
                </li>
                <li>
<a href="/site/forms/postregister/post_register_military/">Military</a>
                </li>
                <li>
                    <a href="/site/forms/postregister/pr_engagement/">Engagement</a>
                </li>
                <li>
                    <a href="/site/forms/postregister/pr_engagement/">Wedding</a>
                </li>
            </ul>
</div>
    </div>
</div></div></div>
                    <div id="tncms-region-mobile-nav-bottom-left-region" class="tncms-region "><div id="tncms-block-1603136" class="tncms-block"><div class="tncms-region-nav" id="htmlHardcoded-region-nav-mobile-nav-left-below">
    <div class="panel-group nav navbar-nav" id="mobile-nav-left-bottom_menu" role="tablist">
        <div class="panel panel-default">
            <div class="panel-heading" role="tab">
                <div class="panel-title">
                    <a aria-controls="mobile-nav-left-bottom_menu-child-1" aria-expanded="false" class="expand-children collapsed pull-right" data-target="#mobile-nav-left-bottom_menu-child-1" data-toggle="collapse"><i class="fas tnt-chevron-down"></i></a> <a href="/site/services//"><i aria-hidden="true" class="fas tnt-cog"></i> Subscriber Services</a>
                </div>
            </div>
            <ul class="collapse nav navbar-nav" id="mobile-nav-left-bottom_menu-child-1"><li>
                    <a href="/subscribe">Start A Subscription</a>
                </li>
                <li>
                    <a href="/managesubscription" target="_blank">Manage Your Subscription</a>
                </li>
                <li>
                    <a href="/newsletters/signup">Get our Newsletters</a>
                </li>
            </ul></div>
        <div class="panel panel-default">
            <div class="panel-heading" role="tab">
                <div class="panel-title">
                    <a aria-controls="mobile-nav-left-bottom_menu-child-3" aria-expanded="false" class="expand-children collapsed pull-right" data-target="#mobile-nav-left-bottom_menu-child-3" data-toggle="collapse"><i class="fas tnt-chevron-down"></i></a> <a href="/site/services"><i aria-hidden="true" class="fas tnt-cubes"></i> Site Services</a>
                </div>
            </div>
            <ul class="collapse nav navbar-nav" id="mobile-nav-left-bottom_menu-child-3"><li>
                    <a href="/newsletters/signup/">Get our Newsletters</a>
                </li>
                <li>
                    <a href="/site/about/">About Us</a>
                </li>
                <li>
                    <a href="/site/contact/">Contact Us</a>
                </li>
                <li>
                    <a href="/site/careers/">Careers</a>
                </li>
                <li>
                    <a href="/site/printing/">Printing</a>
                </li>
                <li>
                    <a href="/site/nie">Newspapers In Education</a>
                </li>
                <li>
                    <a href="/multimedia/">Multimedia</a>
                </li>
                <li>
                    <a href="/multimedia/galleries/">Galleries</a>
                </li>
                <li>
                    <a href="/multimedia/photos/">Photos</a>
                </li>
                <li>
                    <a href="/multimedia/videos/">Videos</a>
                </li>
            </ul></div>
        <div class="panel panel-default">
            <div class="panel-heading" role="tab">
                <div class="panel-title">
                    <a href="http://nl.newsbank.com/sites/pngnp/"><span class="topbarLink"><i class="fas tnt-list-ul"></i> Browse the Archives</span></a>
                </div>
            </div>
        </div>
    </div>
</div></div></div>
                </aside>
            
            
    
            <div class="offcanvas-inner">
                <div class="offcanvas-close-btn"></div>
        
    
        
            <div id="site-top-nav-container" class="hidden-sm hidden-xs hidden-print">
                <header id="site-top-nav" class="container">
                    <div class="row">
                        <div id="topbar-col-one" class="col-md-12">
        <div id="tncms-region-topbar-col-one" class="tncms-region "><div id="tncms-block-1590514" class="tncms-block"><style>
        #swap-toggle-decor-before {
            border-top: 8px solid #ececec;
        }
        #swap-toggle-pr:hover, #swap-toggle-pr.active {
            background-color: #ececec;
        }#swap-toggle-cm:hover, #swap-toggle-cm.active {
                background-color: #ececec;
            }#swap-toggle-js:hover, #swap-toggle-js.active {
                background-color: #ececec;
            }#swap-toggle-bcc:hover, #swap-toggle-bcc.active {
                background-color: #ececec;
            }#swap-toggle-prp:hover, #swap-toggle-prp.active {
                background-color: #ececec;
            }#swap-toggle-br:hover, #swap-toggle-br.active {
                background-color: #ececec;
            }#swap-toggle-fr:hover, #swap-toggle-fr.active {
                background-color: #ad0736;
            }#swap-toggle-eob:hover, #swap-toggle-eob.active {
                background-color: #688a7e;
            }</style>
    
    
        
    
        
    
        
            
        
    
        
    
        
    
        
    
        
    
    
    
        <div class="png-header-swap-nav-wrap" data-where="main">
            <div class="png-header-swap-nav">
                <a id="swap-toggle-pr" class="png-header-swap-menu-item inverted" data-id="header-splash-pr" data-color="#ececec" data-invert="true" href="/">Post Register</a><a id="swap-toggle-cm" class="png-header-swap-menu-item inverted" data-id="header-splash-cm" data-color="#ececec" data-invert="true" href="/messenger">Challis Messenger</a><a id="swap-toggle-js" class="png-header-swap-menu-item inverted" data-id="header-splash-js" data-color="#ececec" data-invert="true" href="/star">Jefferson Star</a><a id="swap-toggle-bcc" class="png-header-swap-menu-item active inverted" data-id="header-splash-bcc" data-color="#ececec" data-invert="true" href="/chronicle">Bingham County</a><a id="swap-toggle-prp" class="png-header-swap-menu-item inverted" data-id="header-splash-prp" data-color="#ececec" data-invert="true" href="/preps">PR Preps</a><a id="swap-toggle-br" class="png-header-swap-menu-item inverted" data-id="header-splash-br" data-color="#ececec" data-invert="true" href="https://www.idahostatejournal.com/business_journal" target="_blank">Business Journal</a><a id="swap-toggle-fr" class="png-header-swap-menu-item" data-id="header-splash-fr" data-color="#ad0736" data-invert="" href="/farmandranch">Farm & Ranch</a><a id="swap-toggle-eob" class="png-header-swap-menu-item" data-id="header-splash-eob" data-color="#688a7e" data-invert="" href="https://www.idahopress.com/eyeonboise/" target="_blank">Eye On Boise</a><div id="swap-toggle-decor-wrap">
                    <div id="swap-toggle-decor">
                        <div id="swap-toggle-decor-before"></div>
                        <div id="swap-toggle-decor-after"></div>
                    </div>
                </div>
            </div>
        </div>
    </div></div>
        <div id="tncms-region-nav-topbar-col-one-nav" class="tncms-region-nav"><ul id="topbar-col-one-nav_menu" class="list-inline nav-list" ></ul></div>
    </div>
                    </div>
                </header>
            </div>
        
    
        
            <div id="site-header-container" class="hidden-sm hidden-xs hidden-print">
                <header id="site-header" class="container" role="banner">
                    
                    <div class="row">
                        <div id="masthead-full-top" class="col-lg-12">
                            <div id="tncms-region-masthead-full-top" class="tncms-region "><div id="tncms-block-1590513" class="tncms-block mysteryHeaderLogo"><style>
        body #site-header-container {
            background-color: #fcfcfc;
            background: #fcfcfc;
            background: -moz-linear-gradient(top, #ececec 0%, #fcfcfc 100%);
            background: -webkit-linear-gradient(top, #ececec 0%, #fcfcfc 100%);
            background: linear-gradient(to bottom, #ececec 0%, #fcfcfc 100%);
            filter: progid:DXImageTransform.Microsoft.gradient( startColorstr='#ececec', endColorstr='#fcfcfc',GradientType=0 );
        }
        
            body.section-messenger #site-header-container {
                background-color: #fcfcfc;
                background: #fcfcfc;
                background: -moz-linear-gradient(top, #ececec 0%, #fcfcfc 100%);
                background: -webkit-linear-gradient(top, #ececec 0%,#fcfcfc 100%);
                background: linear-gradient(to bottom, #ececec 0%,#fcfcfc 100%);
                filter: progid:DXImageTransform.Microsoft.gradient( startColorstr='#ececec', endColorstr='#fcfcfc',GradientType=0 );
            }
        
            body.section-star #site-header-container {
                background-color: #fcfcfc;
                background: #fcfcfc;
                background: -moz-linear-gradient(top, #ececec 0%, #fcfcfc 100%);
                background: -webkit-linear-gradient(top, #ececec 0%,#fcfcfc 100%);
                background: linear-gradient(to bottom, #ececec 0%,#fcfcfc 100%);
                filter: progid:DXImageTransform.Microsoft.gradient( startColorstr='#ececec', endColorstr='#fcfcfc',GradientType=0 );
            }
        
            body.section-chronicle #site-header-container {
                background-color: #fcfcfc;
                background: #fcfcfc;
                background: -moz-linear-gradient(top, #ececec 0%, #fcfcfc 100%);
                background: -webkit-linear-gradient(top, #ececec 0%,#fcfcfc 100%);
                background: linear-gradient(to bottom, #ececec 0%,#fcfcfc 100%);
                filter: progid:DXImageTransform.Microsoft.gradient( startColorstr='#ececec', endColorstr='#fcfcfc',GradientType=0 );
            }
        
            body.section-preps #site-header-container {
                background-color: #fcfcfc;
                background: #fcfcfc;
                background: -moz-linear-gradient(top, #ececec 0%, #fcfcfc 100%);
                background: -webkit-linear-gradient(top, #ececec 0%,#fcfcfc 100%);
                background: linear-gradient(to bottom, #ececec 0%,#fcfcfc 100%);
                filter: progid:DXImageTransform.Microsoft.gradient( startColorstr='#ececec', endColorstr='#fcfcfc',GradientType=0 );
            }
        
            body.section-https://www.idahostatejournal.com/business_journal #site-header-container {
                background-color: #fcfcfc;
                background: #fcfcfc;
                background: -moz-linear-gradient(top, #ececec 0%, #fcfcfc 100%);
                background: -webkit-linear-gradient(top, #ececec 0%,#fcfcfc 100%);
                background: linear-gradient(to bottom, #ececec 0%,#fcfcfc 100%);
                filter: progid:DXImageTransform.Microsoft.gradient( startColorstr='#ececec', endColorstr='#fcfcfc',GradientType=0 );
            }
        
            body.section-farmandranch #site-header-container {
                background-color: #ad0736;
                background: #ad0736;
                background: -moz-linear-gradient(top, #ad0736 0%, #ad0736 100%);
                background: -webkit-linear-gradient(top, #ad0736 0%,#ad0736 100%);
                background: linear-gradient(to bottom, #ad0736 0%,#ad0736 100%);
                filter: progid:DXImageTransform.Microsoft.gradient( startColorstr='#ad0736', endColorstr='#ad0736',GradientType=0 );
            }
        
            body.section-https://www.idahopress.com/eyeonboise/ #site-header-container {
                background-color: #789e91;
                background: #789e91;
                background: -moz-linear-gradient(top, #688a7e 0%, #789e91 100%);
                background: -webkit-linear-gradient(top, #688a7e 0%,#789e91 100%);
                background: linear-gradient(to bottom, #688a7e 0%,#789e91 100%);
                filter: progid:DXImageTransform.Microsoft.gradient( startColorstr='#688a7e', endColorstr='#789e91',GradientType=0 );
            }
        
    
        
    </style><div class="site-logo-container text-left">
                <a href="/chronicle" title="Bingham County"><img class="img-responsive" alt="Bingham County" src="https://bloximages.chicago2.vip.townnews.com/postregister.com/content/tncms/live/libraries/flex/components/site/resources/images/logos/bcc-logo-main.png?_dc=1589305082"></a>
                
            </div></div><div id="tncms-block-1590519" class="tncms-block">
            <style>
                #siteHeaderContainerCTA {
                    display: block;
                    position: absolute;
                    top: 0;
                    right: 0;
                    width: 400px;
                    height: 100px;
                    padding-top: 5px;
                    overflow: hidden;
                    text-align: center;
                }
                #siteHeaderContainerCTA:hover {
                    text-decoration: none;
                }
                #siteHeaderContainerCTA .siteHeaderContainerCTA-line1 {
		font-family: verdana;
		font-weight: 700;
		font-size: 20px;
		line-height: 30px;
		color: black;
		background-color:orange;
		border:  5px solid orange;
		border-radius: 25px;
		width:250px;
		}
                a:link {
                  text-decoration: none;
                }

                a:visited {
                  text-decoration: none;
                }

                a:hover {
                  text-decoration: none;
                }

                a:active {
                  text-decoration: none;                }
                #siteHeaderContainerCTA .siteHeaderContainerCTA-line2 {
                    font-weight: 700;
                    font-size: 12px;
                    line-height: 15px;
                    color: #aaaaaa;
                }
                #siteHeaderContainerCTA .siteHeaderContainerCTA-line3 {
                    font-weight: 700;
                    font-size: 21px;
                    line-height: 30px;
                    color: #444444;
                    transition: all 200ms ease;
                }
                #siteHeaderContainerCTA:hover .siteHeaderContainerCTA-line3 {
                    color: #222222;
                }
                .mysteryHeaderLogo {
                    margin-top:  0px;
                }
                .mysteryHeaderSocial {
                    margin-top: 100px;
                }
                .mysteryHeaderWeather {
                    margin-top: 100px;
                }
            </style>
        
        
        <a id="siteHeaderContainerCTA" href="/chronicle/subscribe">
            <div class="siteHeaderContainerCTA-line1">SUBSCRIBE NOW!</div>
            <div class="siteHeaderContainerCTA-line2"></div>
            <div class="siteHeaderContainerCTA-line3"></div>
        </a>
        </div><div id="tncms-block-1590516" class="tncms-block mysteryHeaderSocial">
    
        
    
        
    
        
    
        
    
        
    
        
    
        
    
        
    
        
    
    
        <div class="follow-links-1590516">
            <section id="block-1590516" class="block emphasis-h3   ">
                <ul class="list-inline"><li><a href="https://www.facebook.com/BinghamNewsChronicle" title="Facebook" target="_blank" class="btn btn-md btn-link"><i class="fab tnt-facebook-f"></i><span class="sr-only">Facebook</span></a></li></ul>
            </section>
        </div>
        <div class="clearfix"></div>
    </div><div id="tncms-block-1590517" class="tncms-block mysteryHeaderWeather"><style>
            #site-header-container #weather-1590517 .current-conditions a {  }
            #site-header-container #weather-1590517 .current-conditions a:hover {  }
        </style>
        <div id="weather-1590517" class="weather-current size-  inverted">
            <ul class="list-unstyled">
                <li class="current-conditions ">
                    <a href="/weather/?weather_zip=83221" class="dropdown-toggle" >
                        <span class="icon pull-left">
                            
                            <span class="fas tnt-wi-night-cloudy"></span>
                        </span>
                        <span class="pull-left temp-desc ">
                            <span class="temp">40&deg;</span>
                            
                                <span class="cond">Cloudy </span>
                            
                        </span>
                        <span class="clearfix"></span>
                    </a>
                    
                </li>
            </ul>
        </div>
        
            <div class="clearfix"></div>
        </div></div>
                        </div>
                    </div>
                    <div class="row">
                        
                        <div id="masthead-col-one" class="col-md-4 col-sm-4"><div id="tncms-region-masthead-col-one" class="tncms-region "></div></div>
    <div id="masthead-col-two" class="col-md-4 col-sm-4"><div id="tncms-region-masthead-col-two" class="tncms-region "></div></div>
    <div id="masthead-col-three" class="col-md-4 col-sm-4"><div id="tncms-region-masthead-col-three" class="tncms-region "></div></div>
                    </div>
                    <div class="row">
                        <div id="masthead-full-bottom" class="col-lg-12">
                            <div id="tncms-region-masthead-full-bottom" class="tncms-region "><div id="tncms-block-1913816" class="tncms-block"><style>
.apg-alert-bw {
    background-color: white;
    color: black;
}
</style><div class="grid" style="padding-top: 20px;">
<div class="row">
    <div class="alert alert-info" role="alert">
Note: We've recently updated our online systems. If you can't login please try resetting your password. You must login with an email address. If you don't have an email associated with your account email 
<a href="mailto:circulation@postregister.com" style="font-weight: bold;">circulation@postregister.com</a> for help creating one. 
    </div>
</div>
</div></div></div>
                        </div>
                    </div>
                    
                </header>
            </div>
        
    
        
            <div id="site-navbar-container" class="hidden-print affix-top">
                
                <nav id="main-navigation" class="navbar yamm navbar-default container navbar-static">
                    
                    <div class="navbar-header">
                        
                        
                            <button type="button" class=" hamburger-desktop fluid-header navbar-toggle " data-toggle="offcanvas" data-target="left">
                                <span class="sr-only">Toggle navigation</span>
                                <span class="icon-bar" style='margin: 0 auto 4px auto;'></span>
                                <span class="icon-bar" style='margin: 0 auto 4px auto;'></span>
                                <span class="icon-bar" style='margin: 0 auto;'></span>
                                <span class="visible-lg visible-md sr-only-show">Full Menu</span>
                            </button>
                            
                        
                        
    
                        
                            <div class="navbar-brand hidden-md hidden-lg pos_left">
                                
                                    <div id="tncms-region-main-nav-brand" class="tncms-region "><div id="tncms-block-1590511" class="tncms-block"><div id="site-logo-1590511" class="site-logo-container swap-site-mobile">
        <div class="logo-middle swap-site-mobile-current">
            <a href="/chronicle" title="Bingham County"><img class="img-responsive" alt="Bingham County" src="https://bloximages.chicago2.vip.townnews.com/postregister.com/content/tncms/live/libraries/flex/components/site/resources/images/logos/bcc-logo-mobile.png?_dc=1550767538"></a>
                    <div id="swap-site-mobile-choice-trigger"><i class="fas tnt-chevron-down" aria-hidden="true"></i></div>
        </div>
        <div id="swap-site-mobile-choices">
            <a href="/" title="Post Register"><img class="img-responsive" alt="Post Register" src="https://bloximages.chicago2.vip.townnews.com/postregister.com/content/tncms/live/libraries/flex/components/site/resources/images/logos/pr-logo-btn-sm.png?_dc=1530298572">Post Register</a><a href="/messenger" title="Challis Messenger"><img class="img-responsive" alt="Challis Messenger" src="https://bloximages.chicago2.vip.townnews.com/postregister.com/content/tncms/live/libraries/flex/components/site/resources/images/logos/cm-logo-btn-sm.png?_dc=1530298491">Challis Messenger</a><a href="/star" title="Jefferson Star"><img class="img-responsive" alt="Jefferson Star" src="https://bloximages.chicago2.vip.townnews.com/postregister.com/content/tncms/live/libraries/flex/components/site/resources/images/logos/js-logo-btn-sm.png?_dc=1530222238">Jefferson Star</a><a href="/chronicle" title="Bingham County"><img class="img-responsive" alt="Bingham County" src="https://bloximages.chicago2.vip.townnews.com/postregister.com/content/tncms/live/libraries/flex/components/site/resources/images/logos/bcc-logo-btn-sm.png?_dc=1550768978">Bingham County</a><a href="/preps" title="PR Preps"><img class="img-responsive" alt="PR Preps" src="https://bloximages.chicago2.vip.townnews.com/postregister.com/content/tncms/live/libraries/flex/components/site/resources/images/logos/prp-logo-btn-sm.png?_dc=1530222319">PR Preps</a><a href="https://www.idahostatejournal.com/business_journal" target="_blank" title="Business Journal"><img class="img-responsive" alt="Business Journal" src="https://bloximages.chicago2.vip.townnews.com/postregister.com/content/tncms/live/libraries/flex/components/site/resources/images/logos/br-logo-btn-sm.png?_dc=1530215286">Business Journal</a><a href="/farmandranch" title="Farm & Ranch"><img class="img-responsive" alt="Farm & Ranch" src="https://bloximages.chicago2.vip.townnews.com/postregister.com/content/tncms/live/libraries/flex/components/site/resources/images/logos/fr-logo-btn-sm.png?_dc=1530222174">Farm & Ranch</a><a href="https://www.idahopress.com/eyeonboise/" target="_blank" title="Eye On Boise"><img class="img-responsive" alt="Eye On Boise" src="https://bloximages.chicago2.vip.townnews.com/postregister.com/content/tncms/live/libraries/flex/components/site/resources/images/logos/ip-logo-btn-sm.png?_dc=1530199359">Eye On Boise</a></div>
    </div></div></div>
                                
                            </div>
                        
    
                                        
                    </div>
    
                    
                        <div id="navbar-collapse" class="navbar-collapse collapse">
                            
                                <div class="pull-right">
                                    <div id="tncms-region-main-nav-right-region" class="tncms-region "><div id="tncms-block-1655890" class="tncms-block"><ul id="site-search-1655890-dropdown" class="hidden-print nav navbar-nav navbar-right ">
        <li class="search-form-dropdown dropdown">
            <a  onclick="javascript:void(0); return false;"  class="dropdown-toggle" data-hover="dropdown" data-hover-delay="250" data-toggle="dropdown"><span class="fas tnt-search"></span></a>
            <ul class="dropdown-menu">
                <li><form id="site-search-1655890" aria-labelledby="site-search-button-1655890" action="/chronicle/search/" method="GET" >
    <input type="hidden" name="l" value="25">
    
        
        <input type="hidden" name="sort" value="relevance">
    
    
    
    
    <input type="hidden" name="f" value="html">
    
        
        <input type="hidden" name="t" value="article,video,youtube,collection">
    
    <input type="hidden" name="app" value="editorial">
    <input type="hidden" name="nsa" value="eedition">
    <div class="site-search-form input-group default input-group-lg ">
        <input id="site-search-1655890-term" name="q" title="Site Search" type="text" placeholder="Search..." class="form-control" autocomplete="off">
        <input type="submit" class="hide" value="Search">
        <span class="input-group-btn">
            <button id="site-search-1655890-btn" class="btn btn-primary" aria-label="Submit Site Search" type="submit">
                
	                <span class="hidden-xl hidden-lg hidden-md fas tnt-search"></span>
	                <span id="site-search-button-1655890" class="hidden-xs hidden-sm">Search</span>
                
            </button>
        </span>
    </div>
    <div class="clearfix"></div>
</form></ul>
        </li>
    </ul>
 

<script>
    $('#site-search-1655890-btn').on(__tnt.client.clickEvent, function(){
        $('#site-search-1655890').submit();
        return false;
    });

    $('#site-search-1655890').on('submit', function(){
        // Filter query
        var sQueryFiltered = $("#site-search-1655890 input[name=q]").val().replace(/\?/g, '');
    $("#site-search-1655890 input[name=q]").val( sQueryFiltered );

        if( $('#site-search-1655890-term').val() ){
            return true;
        }else{
            return false;
        }
    });</script>
</div></div>
                                    <div id="tncms-region-nav-main-nav-right-nav" class="tncms-region-nav"><ul id="main-nav-right-nav_menu" class="nav navbar-nav" role="navigation" aria-label="Main"><li>
                <a class="nav-link   tnt-section-e-edition"  href="/eedition/binghamcountychronicle/"  tabindex="0">
                    <span class="nav-label">E-Edition</span>
                </a></li><li>
                <a class="nav-link   tnt-section-subscribe"  href="/chronicle/subscribe"  tabindex="0">
                    <span class="nav-label">Subscribe</span>
                </a></li></ul></div>
                                </div>
                            
                            <div class="navbar-left">
                                <div id="tncms-region-main-nav-left-region" class="tncms-region "></div>
                                <div id="tncms-region-nav-main-nav" class="tncms-region-nav"><ul id="main-nav_menu" class="nav navbar-nav" role="navigation" aria-label="Main"><li>
                <a class="nav-link   tnt-section-news"  href="/chronicle/news/"  tabindex="0">
                    <span class="nav-label">News</span>
                </a></li><li>
                <a class="nav-link   tnt-section-covid-19"  href="/chronicle/coronavirus/"  tabindex="0">
                    <span class="nav-label">COVID-19</span>
                </a></li><li>
                <a class="nav-link   tnt-section-sports"  href="/chronicle/sports/"  tabindex="0">
                    <span class="nav-label">Sports</span>
                </a></li><li>
                <a class="nav-link   tnt-section-opinion"  href="/chronicle/opinion/"  tabindex="0">
                    <span class="nav-label">Opinion</span>
                </a></li><li>
                <a class="nav-link   tnt-section-obituaries"  href="/chronicle/obituaries/"  tabindex="0">
                    <span class="nav-label">Obituaries</span>
                </a></li><li>
                <a class="nav-link   tnt-section-local-scenes"  href="/chronicle/local_scenes/"  tabindex="0">
                    <span class="nav-label">Local Scenes</span>
                </a></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-milestones"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/chronicle/milestones/"  tabindex="0">
                    <span class="nav-label">Milestones</span>
                </a><ul id="main-nav_menu-child-7" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-anniversaries"  href="/chronicle/milestones/anniversaries/"  tabindex="0">
                    <span class="nav-label">Anniversaries</span>
                </a></li><li>
                <a class="nav-link   tnt-section-birthdays"  href="/chronicle/milestones/birthdays/"  tabindex="0">
                    <span class="nav-label">Birthdays</span>
                </a></li><li>
                <a class="nav-link   tnt-section-births"  href="/chronicle/milestones/births/"  tabindex="0">
                    <span class="nav-label">Births</span>
                </a></li><li>
                <a class="nav-link   tnt-section-engagements"  href="/chronicle/milestones/engagements/"  tabindex="0">
                    <span class="nav-label">Engagements</span>
                </a></li><li>
                <a class="nav-link   tnt-section-missions"  href="/chronicle/milestones/missions/"  tabindex="0">
                    <span class="nav-label">Missions</span>
                </a></li><li>
                <a class="nav-link   tnt-section-weddings"  href="/chronicle/milestones/weddings/"  tabindex="0">
                    <span class="nav-label">Weddings</span>
                </a></li></ul></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-calendar"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/chronicle/local-events/"  tabindex="0">
                    <span class="nav-label">Calendar</span>
                </a><ul id="main-nav_menu-child-8" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-promote-your-event"  href="https://new.evvnt.com/?with_navbar&amp;force_snap_sell&amp;partner=POSTREGISTERN&amp;publisher_url:postregister.com/chronicle#/quick"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Promote Your Event</span>
                </a></li></ul></li><li>
                <a class="nav-link   tnt-section-classifieds"  href="https://www.idahostatejournal.com/classifieds/"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Classifieds</span>
                </a></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-contests"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/chronicle/contests/"  tabindex="0">
                    <span class="nav-label">Contests</span>
                </a><ul id="main-nav_menu-child-10" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-5000-home-improvement-sweepstakes"  href="http://binghamcountychronicle.secondstreetapp.com/5000-Spring-Home-Improvement-Sweepstakes/"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">$5,000 Home Improvement Sweepstakes</span>
                </a></li><li>
                <a class="nav-link   tnt-section-readers-choice"  href="http://binghamcountychronicle.secondstreetapp.com/Readers-Choice-2021/"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Readers' Choice</span>
                </a></li></ul></li></ul></div>
                            </div>
                        </div>
                    
    
                    
                </nav>
                
            </div>
            
                
                    <script>
                        jQuery(document).ready(function($){
                            var sNavContainer = '#site-navbar-container';
                            var sBodyContainer = '#main-body-container';
                            var sNavHeight = $(sNavContainer).height();
                            var iUnfixPoint = 0;
                            if( __tnt.client.platform.ios ){
                                $(sNavContainer).addClass('affix-sticky');
                            } else {
                                $sNavScroll = false;
                                $(window).on('scroll mousewheel', function(){
                                    if( !$sNavScroll ){
                                        $sNavScroll = true;
                                        setTimeout(function(){
                                            var iFixPoint = $(sNavContainer).offset().top;
                                            var iCurrPoint = $(this).scrollTop();
                                            if( iCurrPoint >= iFixPoint && iCurrPoint > iUnfixPoint ){
                                                if( !$(sNavContainer).hasClass('affix') ){ 
                                                    iUnfixPoint = iFixPoint;
                                                    $(sNavContainer).addClass('affix').removeClass('affix-top');
                                                    $(sBodyContainer).css('margin-top', sNavHeight+'px'); 
                                                }
                                            } else {
                                                if( !$(sNavContainer).hasClass('affix-top') ){ 
                                                    $(sNavContainer).removeClass('affix').addClass('affix-top');
                                                    $(sBodyContainer).css('margin-top', 0);
                                                }
                                            }
                                            $sNavScroll = false;
                                        }, 25);
                                    }
                                });
                            }
                        });
                    </script>
                
            
        
        <div id="main-body-container">
    <section id="main-top-container" class="container-fullscreen-region container-fluid">
        
        <div class="fullscreen-region"><div id="tncms-region-global-container-top-fullscreen" class="tncms-region "><div id="tncms-block-1609199" class="tncms-block"></div><div id="tncms-block-1609241" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-1609241" class="tnt-ads dfp-ad" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-1609241');
                        
                });
            </script>
        </div>
    </div>
</div><div id="tncms-block-1830406" class="tncms-block tnc-overlay"><div class="modal promo-designer-modal in centered " id="promo-designer-modal-custom-pop" tabindex="-1" role="dialog" aria-label="Promotional pop up" aria-hidden="true" >
        <div class="modal-dialog modal-md centered">
            <div class="modal-content">
                <div class="modal-body"><section id="block-1830406" class="block emphasis-h3   " ><div class="promo-design"><div class="card-bg-color rounded_rectangle">
        <div class="card-panel panel"><button type="button" class="close" data-dismiss="modal" aria-label="Close">
                <span class="tnt-stack" aria-hidden="true">
                    <i class="fas tnt-circle tnt-inverse tnt-stack-1x"></i>
                    <i class="fas tnt-times-circle tnt-stack-1x"></i>
                </span>
            </button>
             <div class="panel-body">
                <div class="promo-designer-wrapper">
                    
                        <div class="headline large light text-shadow">
                            Support local journalism
                        </div>
                    
                    
                        <p class="text light text-shadow">
                            Now, more than ever, the world needs trustworthy reporting—but good journalism isn’t free. Please support us by making a contribution.
                        </p>
                    <div class="promo-design-button">
                            <a href="/contribute">
                                <button type="button" class="btn btn-danger btn-lg">Contribute</button>
                            </a>
                        </div>
                </div>   
            </div>
        </div>
    </div>
</div></section></div>
            </div>
        </div>
    </div></div></div></div>
    </section>
    <section id="main-page-container" class="container">
        <div class="row">
                <div id="asset-container-top" class="col-md-12"><div id="tncms-region-asset_container_top" class="tncms-region hidden-print"></div></div>
            
            <div class="col-md-12"><div id="tncms-region-global-container-top" class="tncms-region "><div id="tncms-block-1609232" class="tncms-block hidden-sm hidden-xs"><div class="tnt-ads-container text-center  " >
        <div id="ad-1609232" class="tnt-ads dfp-ad" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-1609232');
                        
                });
            </script>
        </div>
    </div>
</div><div id="tncms-block-1609239" class="tncms-block hidden-lg hidden-md"><div class="tnt-ads-container text-center  " >
        <div id="ad-1609239" class="tnt-ads dfp-ad" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-1609239');
                        
                });
            </script>
        </div>
    </div>
</div></div></div>
        </div><div id="modal-image-62e25782-f7c0-5492-907b-1329b099e73e" class="modal fullscreen in modal-image image-default modal-62e25782-f7c0-5492-907b-1329b099e73e" role="dialog" aria-hidden="true" data-lazy-content>
        <template>
            <button type="button" class="close hidden-print" data-dismiss="modal">
                <span aria-hidden="true" class="control-left fas tnt-times-circle"></span>
                <span class="sr-only">Close</span>
            </button>
            <div class="modal-dialog modal-lg">
                <div class="modal-content">
                    <div class="modal-body">
                        <div class="modal-image-container"><figure class="photo layout-horizontal letterbox-style-default">
            <div class="image" 
                >
                
                
                
                
        <img
                    src="https://bloximages.chicago2.vip.townnews.com/postregister.com/content/tncms/assets/v3/editorial/6/2e/62e25782-f7c0-5492-907b-1329b099e73e/6078ccf2c539f.image.jpg?resize=400%2C267"
                    srcset="https://bloximages.chicago2.vip.townnews.com/postregister.com/content/tncms/assets/v3/editorial/6/2e/62e25782-f7c0-5492-907b-1329b099e73e/6078ccf2c539f.image.jpg?resize=150%2C100 150w, https://bloximages.chicago2.vip.townnews.com/postregister.com/content/tncms/assets/v3/editorial/6/2e/62e25782-f7c0-5492-907b-1329b099e73e/6078ccf2c539f.image.jpg?resize=200%2C133 200w, https://bloximages.chicago2.vip.townnews.com/postregister.com/content/tncms/assets/v3/editorial/6/2e/62e25782-f7c0-5492-907b-1329b099e73e/6078ccf2c539f.image.jpg?resize=225%2C150 225w, https://bloximages.chicago2.vip.townnews.com/postregister.com/content/tncms/assets/v3/editorial/6/2e/62e25782-f7c0-5492-907b-1329b099e73e/6078ccf2c539f.image.jpg?resize=300%2C200 300w, https://bloximages.chicago2.vip.townnews.com/postregister.com/content/tncms/assets/v3/editorial/6/2e/62e25782-f7c0-5492-907b-1329b099e73e/6078ccf2c539f.image.jpg?resize=400%2C267 400w, https://bloximages.chicago2.vip.townnews.com/postregister.com/content/tncms/assets/v3/editorial/6/2e/62e25782-f7c0-5492-907b-1329b099e73e/6078ccf2c539f.image.jpg?resize=540%2C360 540w, https://bloximages.chicago2.vip.townnews.com/postregister.com/content/tncms/assets/v3/editorial/6/2e/62e25782-f7c0-5492-907b-1329b099e73e/6078ccf2c539f.image.jpg?resize=640%2C427 640w, https://bloximages.chicago2.vip.townnews.com/postregister.com/content/tncms/assets/v3/editorial/6/2e/62e25782-f7c0-5492-907b-1329b099e73e/6078ccf2c539f.image.jpg?resize=750%2C500 750w, https://bloximages.chicago2.vip.townnews.com/postregister.com/content/tncms/assets/v3/editorial/6/2e/62e25782-f7c0-5492-907b-1329b099e73e/6078ccf2c539f.image.jpg?resize=990%2C660 990w, https://bloximages.chicago2.vip.townnews.com/postregister.com/content/tncms/assets/v3/editorial/6/2e/62e25782-f7c0-5492-907b-1329b099e73e/6078ccf2c539f.image.jpg?resize=1035%2C690 1035w, https://bloximages.chicago2.vip.townnews.com/postregister.com/content/tncms/assets/v3/editorial/6/2e/62e25782-f7c0-5492-907b-1329b099e73e/6078ccf2c539f.image.jpg?resize=1200%2C800 1200w, https://bloximages.chicago2.vip.townnews.com/postregister.com/content/tncms/assets/v3/editorial/6/2e/62e25782-f7c0-5492-907b-1329b099e73e/6078ccf2c539f.image.jpg?resize=1333%2C888 1333w, https://bloximages.chicago2.vip.townnews.com/postregister.com/content/tncms/assets/v3/editorial/6/2e/62e25782-f7c0-5492-907b-1329b099e73e/6078ccf2c539f.image.jpg?resize=1476%2C984 1476w, https://bloximages.chicago2.vip.townnews.com/postregister.com/content/tncms/assets/v3/editorial/6/2e/62e25782-f7c0-5492-907b-1329b099e73e/6078ccf2c539f.image.jpg?resize=1763%2C1175 2008w"
                    sizes="100vw"
                    
                    width="1763"
                    height="1175"
                    alt="Grizzlies outlast Broncos"
                    class="img-responsive true-size default" />
                
                
            </div>
            
                
                
            
        </figure></div>
                    </div>
                </div>
            </div>
            <div class="modal-caption">
        <div class="caption-container">
                <span class="pull-right photo-carousel-caption-toggle" data-toggle="collapse" data-instance="#carousel-modal-image-62e25782-f7c0-5492-907b-1329b099e73e" data-target=".caption-inner-modal-image-62e25782-f7c0-5492-907b-1329b099e73e">
                    <i class="fas tnt-minus-circle"></i>
                </span>
            <div class="caption-inner-modal-image-62e25782-f7c0-5492-907b-1329b099e73e collapse in"><div class="caption-text"><div class="subscriber-preview"><p>Bronco sliding into home.</p></div></div><div class="card-meta">
                        <ul class="list-inline">
                                    
                                    
                                        <li class="credit"><span  class="tnt-byline">FRED DAVIS FILE PHOTO</span></li>
                                    
                                
                            
                        </ul>
                    </div>
                    <div class="photo-share">
                        <ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.postregister.com%2Fgrizzlies-outlast-broncos%2Fimage_62e25782-f7c0-5492-907b-1329b099e73e.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/grizzlies-outlast-broncos/image_62e25782-f7c0-5492-907b-1329b099e73e.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"62e25782-f7c0-5492-907b-1329b099e73e"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Grizzlies%20outlast%20Broncos&via=thepostregister&url=https%3A%2F%2Fwww.postregister.com%2Fgrizzlies-outlast-broncos%2Fimage_62e25782-f7c0-5492-907b-1329b099e73e.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/grizzlies-outlast-broncos/image_62e25782-f7c0-5492-907b-1329b099e73e.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"62e25782-f7c0-5492-907b-1329b099e73e"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.postregister.com/grizzlies-outlast-broncos/image_62e25782-f7c0-5492-907b-1329b099e73e.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/grizzlies-outlast-broncos/image_62e25782-f7c0-5492-907b-1329b099e73e.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"62e25782-f7c0-5492-907b-1329b099e73e"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.postregister.com/tncms/asset/editorial/62e25782-f7c0-5492-907b-1329b099e73e" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"62e25782-f7c0-5492-907b-1329b099e73e"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BPost%20Register%5D%20Grizzlies%20outlast%20Broncos&body=https%3A%2F%2Fwww.postregister.com%2Fgrizzlies-outlast-broncos%2Fimage_62e25782-f7c0-5492-907b-1329b099e73e.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"62e25782-f7c0-5492-907b-1329b099e73e"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/grizzlies-outlast-broncos/image_62e25782-f7c0-5492-907b-1329b099e73e.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"62e25782-f7c0-5492-907b-1329b099e73e"}'  rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-62e25782-f7c0-5492-907b-1329b099e73e-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="62e25782-f7c0-5492-907b-1329b099e73e" >
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="62e25782-f7c0-5492-907b-1329b099e73e" class="save-list-62e25782-f7c0-5492-907b-1329b099e73e-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="62e25782-f7c0-5492-907b-1329b099e73e" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="images" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>

                    </div>
            </div>
        </div>
    </div>
            <style>
                #modal-image-62e25782-f7c0-5492-907b-1329b099e73e img { max-height: 1175px; }
            </style>
        </template>
    </div><article itemscope itemtype="https://schema.org/Article" id="asset-5cbf7829-f2cc-573c-bd42-8ed8787f5b51" class="asset article-default"  data-url="https://www.postregister.com/chronicle/sports/grizzlies-outlast-broncos-in-hcc-slugfest/article_5cbf7829-f2cc-573c-bd42-8ed8787f5b51.html">
    <span itemscope itemtype="http://schema.org/SpeakableSpecification">
        <meta itemprop="cssSelector" content=".asset-header .headline" />
        <meta itemprop="cssSelector" content=".asset-content p:first-of-type" />
    </span>
    <meta itemprop="description" content="BLACKFOOT – It was supposed to be the middle game of a three-game set between the top two teams in the 4A division of the High Country Conference baseball standings. Skyline had hosted the Broncos of Blackfoot a day earlier and took one on the chin to the tune of an 18-0 clobbering and many of those who braved the wind, cold, rain and some snowflakes expected more of the same on Wednesday. "/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
        <div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="url" content="https://bloximages.chicago2.vip.townnews.com/postregister.com/content/tncms/assets/v3/editorial/6/2e/62e25782-f7c0-5492-907b-1329b099e73e/6078ccf2c539f.image.jpg?resize=945%2C630">
            <meta itemprop="width" content="945">
            <meta itemprop="height" content="630">
        </div>
        <meta itemprop="name" content="postregister.com">
    </div>
    <link itemprop="mainEntityOfPage" href="https://www.postregister.com/chronicle/sports/grizzlies-outlast-broncos-in-hcc-slugfest/article_5cbf7829-f2cc-573c-bd42-8ed8787f5b51.html" />
    <div class="asset-paging-container hidden-print" data-settings='{"assetType":"article","hasPageBreak":false,"isObit":false,"nextUrl":"https:\/\/www.postregister.com\/tncms\/search\/mlt\/?origin=5cbf7829-f2cc-573c-bd42-8ed8787f5b51&app=editorial&preview=1&type=article%2Ccollection%2Cvideo%2Cyoutube","uuid":"5cbf7829-f2cc-573c-bd42-8ed8787f5b51","isFluid":false,"isAdminVenue":false}'>
            <div id="asset-paging-5cbf7829-f2cc-573c-bd42-8ed8787f5b51" class="asset-paging">
                <div id="paging-prev-5cbf7829-f2cc-573c-bd42-8ed8787f5b51" class="paging-link prev offset"></div>
                <div id="paging-next-5cbf7829-f2cc-573c-bd42-8ed8787f5b51" class="paging-link next offset"></div>
                <div class="clearfix"></div>
            </div>
        </div>
        <template id="asset-paging-template">
            <a class="animate arrow text-center">
                <span class=""></span>
                <span class="animate direction hidden-sm hidden-xs text-primary"></span>
            </a>
            <div class="animate item">
                <div class="dismiss" onclick="document.body.classList.add('trigger-disabled'); document.body.classList.remove('trigger-next'); return false;">
                    <span class="tnt-stack" aria-hidden="true">
                        <i class="fas tnt-circle tnt-inverse tnt-stack-1x"></i>
                        <i class="fas tnt-times-circle tnt-stack-1x"></i>
                    </span>
                </div>
                <div class="inner">
                    <a class="overlay">
                        <span class="sr-only"></span>
                    </a>
                    <div class="head text-uppercase">
                        <small></small>
                    </div>
                    <div class="media">
                        <div class="media-body">
                            <h6 class="media-heading"></h6>
                            <p class="hidden-xs"></p>
                        </div>
                    </div>
                    <div class="clearfix"></div>
                </div>
            </div>
        </template><div class="asset-masthead ">
        <header class="asset-header">
    
    <h1 itemprop="headline" class="headline">
        <span>
            
            Grizzlies outlast Broncos in HCC slugfest
        </span>
    </h1>
    
    <div class="meta">
        <span>
            <ul class="list-inline">
        <li><span itemprop="author" class="tnt-byline">
By FRED DAVIS
fdavis@bcchron.com
</span></li>
        
        
            <li class="visible-print">
        <time datetime="2021-04-15T22:00:00-06:00" class="tnt-date asset-date text-muted">
            Apr 15, 2021
        </time></li>
            <li class="hidden-print">
        <time datetime="2021-04-15T22:00:00-06:00" class="tnt-date asset-date text-muted">30 min ago</time></li>
        
        
            <li class="hidden-print"><a href="https://www.postregister.com/chronicle/sports/grizzlies-outlast-broncos-in-hcc-slugfest/article_5cbf7829-f2cc-573c-bd42-8ed8787f5b51.html#comments" class="cm"><span class="fas tnt-comments"></span> <span twt-comment-count="https://www.postregister.com/chronicle/sports/grizzlies-outlast-broncos-in-hcc-slugfest/article_5cbf7829-f2cc-573c-bd42-8ed8787f5b51.html" twt-article-id="5cbf7829-f2cc-573c-bd42-8ed8787f5b51">0</span></a></li>
        
        
    </ul>
        </span>
    </div>
    <meta itemprop="dateCreated" content="2021-04-15T22:00:00-06:00">
    <meta itemprop="datePublished" content="2021-04-15T22:00:00-06:00">
    <meta itemprop="dateModified" content="2021-04-15T22:00:00-06:00">
</header>
        
        
            <div class="share-container headline-right pull-right hidden-xs" data-subscription-required-remove><ul class="social-share-links hidden-print list-unstyled stacked icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.postregister.com%2Fchronicle%2Fsports%2Fgrizzlies-outlast-broncos-in-hcc-slugfest%2Farticle_5cbf7829-f2cc-573c-bd42-8ed8787f5b51.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/chronicle/sports/grizzlies-outlast-broncos-in-hcc-slugfest/article_5cbf7829-f2cc-573c-bd42-8ed8787f5b51.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"5cbf7829-f2cc-573c-bd42-8ed8787f5b51"}' >
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Share">
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Grizzlies%20outlast%20Broncos%20in%20HCC%20slugfest&via=thepostregister&url=https%3A%2F%2Fwww.postregister.com%2Fchronicle%2Fsports%2Fgrizzlies-outlast-broncos-in-hcc-slugfest%2Farticle_5cbf7829-f2cc-573c-bd42-8ed8787f5b51.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/chronicle/sports/grizzlies-outlast-broncos-in-hcc-slugfest/article_5cbf7829-f2cc-573c-bd42-8ed8787f5b51.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"5cbf7829-f2cc-573c-bd42-8ed8787f5b51"}' >
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Tweet">
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.postregister.com/chronicle/sports/grizzlies-outlast-broncos-in-hcc-slugfest/article_5cbf7829-f2cc-573c-bd42-8ed8787f5b51.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/chronicle/sports/grizzlies-outlast-broncos-in-hcc-slugfest/article_5cbf7829-f2cc-573c-bd42-8ed8787f5b51.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"5cbf7829-f2cc-573c-bd42-8ed8787f5b51"}' >
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="WhatsApp">
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.postregister.com/tncms/asset/editorial/5cbf7829-f2cc-573c-bd42-8ed8787f5b51" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"5cbf7829-f2cc-573c-bd42-8ed8787f5b51"}'  rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="SMS">
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BPost%20Register%5D%20Grizzlies%20outlast%20Broncos%20in%20HCC%20slugfest&body=https%3A%2F%2Fwww.postregister.com%2Fchronicle%2Fsports%2Fgrizzlies-outlast-broncos-in-hcc-slugfest%2Farticle_5cbf7829-f2cc-573c-bd42-8ed8787f5b51.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"5cbf7829-f2cc-573c-bd42-8ed8787f5b51"}'  rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Email">
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li></ul></div>
        
    </div>

    

    <div class="row">
        <div class="main-content col-lg-8 col-md-7 has-sidebar"><div class="main-content-wrap">
            <div id="tncms-region-article_top" class="tncms-region hidden-print"></div>
            
            <div class="asset-photo card"><figure class="photo layout-horizontal hover-expand letterbox-style-default"><span class="expand hidden-print"
               
               data-toggle="modal"
                
                    data-target=".modal-62e25782-f7c0-5492-907b-1329b099e73e" 
                    >
                       <span class="fas tnt-expand"></span>
                   </span>
            
            <div class="image" 
                 
                    data-toggle="modal" 
                     
                    data-target=".modal-62e25782-f7c0-5492-907b-1329b099e73e" 
                    >
                
                
                
                
        <div itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="width" content="1763">
            <meta itemprop="height" content="1175">
            <meta itemprop="contentUrl" content="https://bloximages.chicago2.vip.townnews.com/postregister.com/content/tncms/assets/v3/editorial/6/2e/62e25782-f7c0-5492-907b-1329b099e73e/6078ccf2c539f.image.jpg?resize=1200%2C800">
            <meta itemprop="url" content="https://bloximages.chicago2.vip.townnews.com/postregister.com/content/tncms/assets/v3/editorial/6/2e/62e25782-f7c0-5492-907b-1329b099e73e/6078ccf2c539f.image.jpg?resize=1200%2C800">
        <img
                    src="https://bloximages.chicago2.vip.townnews.com/postregister.com/content/tncms/assets/v3/editorial/6/2e/62e25782-f7c0-5492-907b-1329b099e73e/6078ccf2c539f.image.jpg?resize=400%2C267"
                    srcset="https://bloximages.chicago2.vip.townnews.com/postregister.com/content/tncms/assets/v3/editorial/6/2e/62e25782-f7c0-5492-907b-1329b099e73e/6078ccf2c539f.image.jpg?resize=150%2C100 150w, https://bloximages.chicago2.vip.townnews.com/postregister.com/content/tncms/assets/v3/editorial/6/2e/62e25782-f7c0-5492-907b-1329b099e73e/6078ccf2c539f.image.jpg?resize=200%2C133 200w, https://bloximages.chicago2.vip.townnews.com/postregister.com/content/tncms/assets/v3/editorial/6/2e/62e25782-f7c0-5492-907b-1329b099e73e/6078ccf2c539f.image.jpg?resize=225%2C150 225w, https://bloximages.chicago2.vip.townnews.com/postregister.com/content/tncms/assets/v3/editorial/6/2e/62e25782-f7c0-5492-907b-1329b099e73e/6078ccf2c539f.image.jpg?resize=300%2C200 300w, https://bloximages.chicago2.vip.townnews.com/postregister.com/content/tncms/assets/v3/editorial/6/2e/62e25782-f7c0-5492-907b-1329b099e73e/6078ccf2c539f.image.jpg?resize=400%2C267 400w, https://bloximages.chicago2.vip.townnews.com/postregister.com/content/tncms/assets/v3/editorial/6/2e/62e25782-f7c0-5492-907b-1329b099e73e/6078ccf2c539f.image.jpg?resize=540%2C360 540w, https://bloximages.chicago2.vip.townnews.com/postregister.com/content/tncms/assets/v3/editorial/6/2e/62e25782-f7c0-5492-907b-1329b099e73e/6078ccf2c539f.image.jpg?resize=640%2C427 640w, https://bloximages.chicago2.vip.townnews.com/postregister.com/content/tncms/assets/v3/editorial/6/2e/62e25782-f7c0-5492-907b-1329b099e73e/6078ccf2c539f.image.jpg?resize=750%2C500 750w, https://bloximages.chicago2.vip.townnews.com/postregister.com/content/tncms/assets/v3/editorial/6/2e/62e25782-f7c0-5492-907b-1329b099e73e/6078ccf2c539f.image.jpg?resize=990%2C660 990w, https://bloximages.chicago2.vip.townnews.com/postregister.com/content/tncms/assets/v3/editorial/6/2e/62e25782-f7c0-5492-907b-1329b099e73e/6078ccf2c539f.image.jpg?resize=1035%2C690 1035w, https://bloximages.chicago2.vip.townnews.com/postregister.com/content/tncms/assets/v3/editorial/6/2e/62e25782-f7c0-5492-907b-1329b099e73e/6078ccf2c539f.image.jpg?resize=1200%2C800 1200w, https://bloximages.chicago2.vip.townnews.com/postregister.com/content/tncms/assets/v3/editorial/6/2e/62e25782-f7c0-5492-907b-1329b099e73e/6078ccf2c539f.image.jpg?resize=1333%2C888 1333w, https://bloximages.chicago2.vip.townnews.com/postregister.com/content/tncms/assets/v3/editorial/6/2e/62e25782-f7c0-5492-907b-1329b099e73e/6078ccf2c539f.image.jpg?resize=1476%2C984 1476w, https://bloximages.chicago2.vip.townnews.com/postregister.com/content/tncms/assets/v3/editorial/6/2e/62e25782-f7c0-5492-907b-1329b099e73e/6078ccf2c539f.image.jpg?resize=1763%2C1175 2008w"
                    sizes="(min-width: 1200px) 750px, (min-width: 992px) calc(66.70vw - 60px), calc(100vw - 30px)"
                    
                    width="1763"
                    height="1175"
                    alt="Grizzlies outlast Broncos"
                    class="img-responsive full tnt-restrict-img-62e25782-f7c0-5492-907b-1329b099e73e default" />
            </div><style>
                .tnt-restrict-img-62e25782-f7c0-5492-907b-1329b099e73e {
                    max-width: 1763px;
                }
            </style>
                
                
            </div>
            
                
                
                    <figcaption class="caption">
                            
                                <span class="caption-text">
                                    <p>Bronco sliding into home.</p>
                                </span>
                            
                        
                            
                                <span class="credit">
                                    <span  class="tnt-byline">FRED DAVIS FILE PHOTO</span>
                                </span>
                            
                        
                        <span class="clearfix"></span>
                    </figcaption>
                
            
        </figure></div>

            

            

            <div id="tncms-region-article_top_content" class="tncms-region hidden-print"></div>

            <div id="asset-content" data-asset-uuid="5cbf7829-f2cc-573c-bd42-8ed8787f5b51">
                

                <div class="row">
                    <div class="col-lg-12 col-md-12 col-sm-12" data-subscription-required-class="col-xs-12">
                        
                            
                            <div id="share-left-affix" class="share-container content-left hidden-xs" data-subscription-required-remove><ul class="social-share-links hidden-print list-unstyled stacked icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.postregister.com%2Fchronicle%2Fsports%2Fgrizzlies-outlast-broncos-in-hcc-slugfest%2Farticle_5cbf7829-f2cc-573c-bd42-8ed8787f5b51.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/chronicle/sports/grizzlies-outlast-broncos-in-hcc-slugfest/article_5cbf7829-f2cc-573c-bd42-8ed8787f5b51.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"5cbf7829-f2cc-573c-bd42-8ed8787f5b51"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Grizzlies%20outlast%20Broncos%20in%20HCC%20slugfest&via=thepostregister&url=https%3A%2F%2Fwww.postregister.com%2Fchronicle%2Fsports%2Fgrizzlies-outlast-broncos-in-hcc-slugfest%2Farticle_5cbf7829-f2cc-573c-bd42-8ed8787f5b51.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/chronicle/sports/grizzlies-outlast-broncos-in-hcc-slugfest/article_5cbf7829-f2cc-573c-bd42-8ed8787f5b51.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"5cbf7829-f2cc-573c-bd42-8ed8787f5b51"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.postregister.com/chronicle/sports/grizzlies-outlast-broncos-in-hcc-slugfest/article_5cbf7829-f2cc-573c-bd42-8ed8787f5b51.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/chronicle/sports/grizzlies-outlast-broncos-in-hcc-slugfest/article_5cbf7829-f2cc-573c-bd42-8ed8787f5b51.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"5cbf7829-f2cc-573c-bd42-8ed8787f5b51"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.postregister.com/tncms/asset/editorial/5cbf7829-f2cc-573c-bd42-8ed8787f5b51" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"5cbf7829-f2cc-573c-bd42-8ed8787f5b51"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BPost%20Register%5D%20Grizzlies%20outlast%20Broncos%20in%20HCC%20slugfest&body=https%3A%2F%2Fwww.postregister.com%2Fchronicle%2Fsports%2Fgrizzlies-outlast-broncos-in-hcc-slugfest%2Farticle_5cbf7829-f2cc-573c-bd42-8ed8787f5b51.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"5cbf7829-f2cc-573c-bd42-8ed8787f5b51"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/chronicle/sports/grizzlies-outlast-broncos-in-hcc-slugfest/article_5cbf7829-f2cc-573c-bd42-8ed8787f5b51.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"5cbf7829-f2cc-573c-bd42-8ed8787f5b51"}'  rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-5cbf7829-f2cc-573c-bd42-8ed8787f5b51-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="5cbf7829-f2cc-573c-bd42-8ed8787f5b51" >
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="5cbf7829-f2cc-573c-bd42-8ed8787f5b51" class="save-list-5cbf7829-f2cc-573c-bd42-8ed8787f5b51-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="5cbf7829-f2cc-573c-bd42-8ed8787f5b51" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            
                        
                        <div class="asset-body has-fixed-share" data-subscription-required-class="asset-body">
                            
                                <div class="share-container content-above visible-xs" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.postregister.com%2Fchronicle%2Fsports%2Fgrizzlies-outlast-broncos-in-hcc-slugfest%2Farticle_5cbf7829-f2cc-573c-bd42-8ed8787f5b51.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/chronicle/sports/grizzlies-outlast-broncos-in-hcc-slugfest/article_5cbf7829-f2cc-573c-bd42-8ed8787f5b51.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"5cbf7829-f2cc-573c-bd42-8ed8787f5b51"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Grizzlies%20outlast%20Broncos%20in%20HCC%20slugfest&via=thepostregister&url=https%3A%2F%2Fwww.postregister.com%2Fchronicle%2Fsports%2Fgrizzlies-outlast-broncos-in-hcc-slugfest%2Farticle_5cbf7829-f2cc-573c-bd42-8ed8787f5b51.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/chronicle/sports/grizzlies-outlast-broncos-in-hcc-slugfest/article_5cbf7829-f2cc-573c-bd42-8ed8787f5b51.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"5cbf7829-f2cc-573c-bd42-8ed8787f5b51"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.postregister.com/chronicle/sports/grizzlies-outlast-broncos-in-hcc-slugfest/article_5cbf7829-f2cc-573c-bd42-8ed8787f5b51.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/chronicle/sports/grizzlies-outlast-broncos-in-hcc-slugfest/article_5cbf7829-f2cc-573c-bd42-8ed8787f5b51.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"5cbf7829-f2cc-573c-bd42-8ed8787f5b51"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.postregister.com/tncms/asset/editorial/5cbf7829-f2cc-573c-bd42-8ed8787f5b51" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"5cbf7829-f2cc-573c-bd42-8ed8787f5b51"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BPost%20Register%5D%20Grizzlies%20outlast%20Broncos%20in%20HCC%20slugfest&body=https%3A%2F%2Fwww.postregister.com%2Fchronicle%2Fsports%2Fgrizzlies-outlast-broncos-in-hcc-slugfest%2Farticle_5cbf7829-f2cc-573c-bd42-8ed8787f5b51.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"5cbf7829-f2cc-573c-bd42-8ed8787f5b51"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/chronicle/sports/grizzlies-outlast-broncos-in-hcc-slugfest/article_5cbf7829-f2cc-573c-bd42-8ed8787f5b51.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"5cbf7829-f2cc-573c-bd42-8ed8787f5b51"}'  rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-5cbf7829-f2cc-573c-bd42-8ed8787f5b51-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="5cbf7829-f2cc-573c-bd42-8ed8787f5b51" >
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="5cbf7829-f2cc-573c-bd42-8ed8787f5b51" class="save-list-5cbf7829-f2cc-573c-bd42-8ed8787f5b51-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="5cbf7829-f2cc-573c-bd42-8ed8787f5b51" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            

                            <div id="tncms-region-article_body_top" class="tncms-region hidden-print"></div>

                            <div  itemprop="articleBody" class="asset-content  subscriber-premium">
                                <meta itemprop="isAccessibleForFree" content="false"/>
                                
                                
                                <div class="subscriber-preview"><p>BLACKFOOT – It was supposed to be the middle game of a three-game set between the top two teams in the 4A division of the High Country Conference baseball standings. Skyline had hosted the Broncos of Blackfoot a day earlier and took one on the chin to the tune of an 18-0 clobbering and many of those who braved the wind, cold, rain and some snowflakes expected more of the same on Wednesday.</p></div><div class="subscriber-preview"><p>They got nothing that resembled the previous game other than one of the teams would score 18 runs. By the time the two teams wrapped up their game, the final score was 18-16 in favor of the Grizzlies, but it was not what you would expect from the top two teams in the league. First of all, there were a dozen errors in the game, four for Skyline and eight for Blackfoot. There were three home runs in the blustery conditions, two by Blackfoot and one by Skyline. There were 35 hits in the game, not what you might expect from two teams that supposedly had pretty good pitching staffs and there were 10 walks issued by those pitching staffs as well.</p></div><div class="subscriber-only"><p>Both teams had the lead, in fact, Skyline held the lead four times in the game and Blackfoot held the lead three times as the two teams swapped the lead back and forth several times during the game.</p></div><div class="tnt-ads-container text-center  " >
        <div id="fixed-big-ad-top-asset" class="tnt-ads dfp-ad" style="min-height:250px; min-width:300px;" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('fixed-big-ad-top-asset');
                        
                });
            </script>
        </div>
    </div><div id="tncms-region-article_instory_top" class="tncms-region hidden-print"><div id="tncms-block-1907212" class="tncms-block apg-margin-bottom-10">
        <div class='s2nPlayer k-vtMofBxN' data-type='float'></div><script type='text/javascript' src='//embed.sendtonews.com/player3/embedcode.js?fk=vtMofBxN&cid=10534&offsetx=0&offsety=100&floatwidth=400&floatposition=bottom-left' data-type='s2nScript'></script>
    </div></div><div class="subscriber-only"><p>With all that was going on, it was not a game that you would have expected these two teams to have at this point in the season.</p></div><div class="subscriber-only"><p>Following a game that Blackfoot won the day before behind a masterful pitching performance by Candon Dahle, the Broncos were expecting some more of the same as their pitching staff was rested and they the whole team to draw from. Their bats were scalding hot from the previous couple of games and they were on a six-game winning streak. Things definitely looked to be in Blackfoot’s favor, but that is not the way it turned out.</p></div><div class="subscriber-only"><p>Right from the start, things were off for Blackfoot. Dax Whitney started the game and promptly gave up three runs in the top of the first inning. Blackfoot would come back with three runs of their own to tie things up at 3, but Skyline then scored four more runs in the top of the second.</p></div><div class="subscriber-only"><p>The Blackfoot fans took a collective breath in the second when they came back to score and take the lead at 8-7 and many though that order had been restored.</p></div><div class="subscriber-only"><p>Then things really got out of whack. Skyline scored three more runs in the third taking a 10-8 lead and the Broncos were suddenly three pitchers deep into the bullpen and they put up a big 0 in the bottom of the inning and Skyline was in control, especially when they scored another run in the top of the fourth.</p></div><div class="subscriber-only"><p>Blackfoot did what they have done all season long, rally again to take the lead, this time with a four-run bottom of the fourth and they retook the lead 12-11. Back and forth they would go, until Blackfoot seemingly took control in the bottom of the fifth inning with another three spot and held the lead at 15-11.</p></div><div class="subscriber-only"><p>Not so, said the Grizzlies, who scored three runs in the top of the sixth and three more in top of the seventh to hold the lead at 18-16 and the Broncos simply couldn’t answer the bell one more time. The game took so long that the two teams could not begin the second half of the doubleheader, so things ended up pretty much where they started the week, with the Grizzlies holding a one-game lead in the conference standings with a 6-1 record as opposed to Blackfoot’s 4-1 record and the two teams still have a game against each other yet to play.</p></div><div class="subscriber-only"><p>Blackfoot was slated to continue play against Skyline on Thursday, weather permitting, followed by a game against Madison on Friday.</p></div><div class="subscriber-only"><p><strong>SKYLINE 343 103 3 — 18 18 4</strong></p></div><div class="subscriber-only"><p><strong>BLACKFOOT 350 431 0 — 16 17 8</strong></p></div><div class="subscriber-only"><p>Skyline</p></div><div class="subscriber-only"><p>Lineup AB R H RBI BB SO</p></div><div class="subscriber-only"><p>Logan Taggart 4 4 1 0 2 0</p></div><div class="subscriber-only"><p>Braden Owens 5 5 3 1 1 0</p></div><div class="subscriber-only"><p>Chandler Robinson 4 4 3 6 1 0</p></div><div class="subscriber-only"><p>Trey Olson 6 3 4 3 0 1</p></div><div class="subscriber-only"><p>Brayden Nickels 6 0 2 1 0 1</p></div><div class="subscriber-only"><p>Orvis Brown 5 0 3 3 1 0</p></div><div class="subscriber-only"><p>Ian Galbreaith 4 0 0 0 2 1</p></div><div class="subscriber-only"><p>Isaac Harrison 5 0 0 0 0 1</p></div><div class="subscriber-only"><p>Gardels 5 2 2 0 0 1</p></div><div class="subscriber-only"><p>Andrew Nelson — — — — — -</p></div><div class="subscriber-only"><p>Landon Merzlock — — — — — -</p></div><div class="subscriber-only"><p>Totals 44 18 18 14 7 5</p></div><div class="subscriber-only"><p>Batting 2B: Logan Taggart, Trey Olson 2, Brayden Nickels</p></div><div class="subscriber-only"><p>HR: Chandler Robinson</p></div><div class="subscriber-only"><p>TB: Logan Taggart 2, Trey Olson 6, Chandler Robinson 6, Orvis Brown 3, Braden Owens 3, Brayden Nickels 3, Gardels 2</p></div><div class="subscriber-only"><p>RBI: Trey Olson 3, Chandler Robinson 6, Orvis Brown 3, Braden Owens, Brayden Nickels</p></div><div class="subscriber-only"><p>SF: Chandler Robinson</p></div><div class="subscriber-only"><p>ROE: Logan Taggart, Trey Olson, Ian Galbreaith, Isaac Harrison, Orvis Brown, Braden Owens</p></div><div class="subscriber-only"><p>FC: Ian Galbreaith, Isaac Harrison</p></div><div class="subscriber-only"><p>TotalsTeam QAB: 22 (42.31%)</p></div><div class="subscriber-only"><p>Logan Taggart 3, Trey Olson 4, Chandler Robinson 5, Ian Galbreaith 2, Orvis Brown 2, Braden Owens, Brayden Nickels 3, Gardels 2</p></div><div class="subscriber-only"><p>Team LOB: 13FieldingE: Chandler Robinson 2, Braden Owens, Gardels</p></div><div class="subscriber-only"><p>DP: Landon Merzlock</p></div><div class="subscriber-only"><p>Blackfoot</p></div><div class="subscriber-only"><p>Lineup AB R H RBI BB SO</p></div><div class="subscriber-only"><p>Benjamin Wilson 5 3 4 1 0 0</p></div><div class="subscriber-only"><p>Jaden Harris 4 4 3 0 1 0</p></div><div class="subscriber-only"><p>Tyler Vance 4 3 3 5 1 1</p></div><div class="subscriber-only"><p>Jace Grimmett 4 3 1 1 1 1</p></div><div class="subscriber-only"><p>Stryker Wood 4 2 2 4 0 1</p></div><div class="subscriber-only"><p>Dax Whitney 0 0 0 0 0 0</p></div><div class="subscriber-only"><p>Carter Layton 4 0 2 2 0 1</p></div><div class="subscriber-only"><p>Rich Moore 2 0 0 0 0 2</p></div><div class="subscriber-only"><p>Michael Edwards 1 0 0 1 0 1</p></div><div class="tnt-ads-container text-center  " >
        <div id="fixed-big-ad-middle-asset" class="tnt-ads dfp-ad" style="min-height:250px; min-width:300px;" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('fixed-big-ad-middle-asset');
                        
                });
            </script>
        </div>
    </div><div id="tncms-region-article_instory_middle" class="tncms-region hidden-print"></div><div class="subscriber-only"><p>Eli Hayes 1 0 0 0 0 1</p></div><div class="subscriber-only"><p>Jaxon Grimmett 4 1 2 1 0 1</p></div><div class="subscriber-only"><p>Kyler Mills 3 0 0 0 0 0</p></div><div class="subscriber-only"><p>Candon Dahle — — — — — -</p></div><div class="subscriber-only"><p>Ryan Steidley — — — — — -</p></div><div class="subscriber-only"><p>Totals 36 16 17 15 3 9</p></div><div class="subscriber-only"><p>Batting 2B: Jaxon Grimmett</p></div><div class="subscriber-only"><p>HR: Tyler Vance, Stryker Wood</p></div><div class="subscriber-only"><p>TB: Jace Grimmett, Jaxon Grimmett 3, Jaden Harris 3, Carter Layton 2, Tyler Vance 6, Benjamin Wilson 4, Stryker Wood 5</p></div><div class="subscriber-only"><p>RBI: Michael Edwards, Jace Grimmett, Jaxon Grimmett, Carter Layton 2, Tyler Vance 5, Benjamin Wilson, Stryker Wood 4</p></div><div class="subscriber-only"><p>SAC: Kyler Mills</p></div><div class="subscriber-only"><p>SF: Michael Edwards</p></div><div class="subscriber-only"><p>ROE: Stryker Wood</p></div><div class="subscriber-only"><p>FC: Jace Grimmett</p></div><div class="subscriber-only"><p>HBP: Carter Layton, Stryker Wood</p></div><div class="subscriber-only"><p>SB: Jace Grimmett, Carter Layton</p></div><div class="subscriber-only"><p>TotalsTeam QAB: 22 (51.16%)</p></div><div class="subscriber-only"><p>Michael Edwards, Jace Grimmett 4, Jaxon Grimmett, Jaden Harris 3, Carter Layton, Kyler Mills 2, Tyler Vance 4, Benjamin Wilson 4, Stryker Wood 2</p></div><div class="subscriber-only"><p>Team LOB: 6FieldingE: Jace Grimmett, Jaxon Grimmett, Carter Layton, Kyler Mills, Tyler Vance 4</p></div><div class="subscriber-only"><p>Skyline</p></div><div class="subscriber-only"><p>Pitching IP #P S% H R ER SO BB HR</p></div><div class="subscriber-only"><p>Andrew Nelson 3.0 79 .582 9 9 8 4 2 2</p></div><div class="subscriber-only"><p>Chandler Robinson 1.0 32 .562 6 6 6 0 1 0</p></div><div class="subscriber-only"><p>Ian Galbreaith 1.0 18 .389 1 1 1 1 0 0</p></div><div class="subscriber-only"><p>Isaac Harrison 0.1 2 .500 0 0 0 0 0 0</p></div><div class="subscriber-only"><p>Brayden Nickels 1.2 30 .700 1 0 0 4 0 0</p></div><div class="subscriber-only"><p>Logan Taggart 0.0 0 .000 0 0 0 0 0 0</p></div><div class="subscriber-only"><p>Totals 7.0 161 .578 17 16 15 9 3 2</p></div><div class="subscriber-only"><p>Pitching W: Brayden Nickels</p></div><div class="subscriber-only"><p>HBP: Chandler Robinson, Ian Galbreaith</p></div><div class="subscriber-only"><p>WP: Chandler Robinson, Ian Galbreaith 2, Andrew Nelson</p></div><div class="subscriber-only"><p>Pitches-Strikes: Logan Taggart 0-0, Chandler Robinson 32-18, Ian Galbreaith 18-7, Isaac Harrison 2-1, Andrew Nelson 79-46, Brayden Nickels 30-21</p></div><div class="subscriber-only"><p>Groundouts-Flyouts: Logan Taggart 0-0, Chandler Robinson 0-2, Ian Galbreaith 1-1, Isaac Harrison 1-0, Andrew Nelson 3-1, Brayden Nickels 0-1</p></div><div class="subscriber-only"><p>First pitch strikes-Batters faced: Logan Taggart 0-0, Chandler Robinson 7-10, Ian Galbreaith 1-5, Isaac Harrison 0-1, Andrew Nelson 8-20, Brayden Nickels 5-7</p></div><div class="subscriber-only"><p>Blackfoot</p></div><div class="subscriber-only"><p>Pitching IP #P S% H R ER SO BB HR</p></div><div class="subscriber-only"><p>Dax Whitney 1.0 25 .520 4 3 3 0 1 1</p></div><div class="subscriber-only"><p>Ryan Steidley 1.1 51 .549 8 8 7 2 2 0</p></div><div class="subscriber-only"><p>Michael Edwards 2.2 38 .684 3 1 1 2 1 0</p></div><div class="subscriber-only"><p>Jace Grimmett 2.0 53 .528 3 6 3 1 3 0</p></div><div class="subscriber-only"><p>Candon Dahle 0.0 0 .000 0 0 0 0 0 0</p></div><div class="subscriber-only"><p>Totals 7.0 167 .569 18 18 14 5 7 1</p></div><div class="subscriber-only"><p>Pitching L: Jace Grimmett</p></div><div class="subscriber-only"><p>WP: Ryan Steidley 3</p></div><div class="subscriber-only"><p>Pitches-Strikes: Candon Dahle 0-0, Michael Edwards 38-26, Jace Grimmett 53-28, Ryan Steidley 51-28, Dax Whitney 25-13</p></div><div class="subscriber-only"><p>Groundouts-Flyouts: Candon Dahle 0-0, Michael Edwards 1-4, Jace Grimmett 3-1, Ryan Steidley 0-2, Dax Whitney 1-2</p></div><div class="subscriber-only"><p>First pitch strikes-Batters faced: Candon Dahle 0-0, Michael Edwards 9-13, Jace Grimmett 7-16, Ryan Steidley 8-15, Dax Whitney 3-8</p></div><div class="subscriber-only"><p>Stats provided by Game Changer</p></div><div class="tnt-ads-container text-center  " >
        <div id="fixed-big-ad-bottom-asset" class="tnt-ads dfp-ad" style="min-height:250px; min-width:300px;" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('fixed-big-ad-bottom-asset');
                        
                });
            </script>
        </div>
    </div><div id="tncms-region-article_instory_bottom" class="tncms-region hidden-print"></div>
                                <div id="tncms-region-article_bottom_content" class="tncms-region hidden-print"></div>
                                
                            </div>

                            

                            
    


                            
                                <div class="share-container content-below" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.postregister.com%2Fchronicle%2Fsports%2Fgrizzlies-outlast-broncos-in-hcc-slugfest%2Farticle_5cbf7829-f2cc-573c-bd42-8ed8787f5b51.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/chronicle/sports/grizzlies-outlast-broncos-in-hcc-slugfest/article_5cbf7829-f2cc-573c-bd42-8ed8787f5b51.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"5cbf7829-f2cc-573c-bd42-8ed8787f5b51"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Grizzlies%20outlast%20Broncos%20in%20HCC%20slugfest&via=thepostregister&url=https%3A%2F%2Fwww.postregister.com%2Fchronicle%2Fsports%2Fgrizzlies-outlast-broncos-in-hcc-slugfest%2Farticle_5cbf7829-f2cc-573c-bd42-8ed8787f5b51.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/chronicle/sports/grizzlies-outlast-broncos-in-hcc-slugfest/article_5cbf7829-f2cc-573c-bd42-8ed8787f5b51.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"5cbf7829-f2cc-573c-bd42-8ed8787f5b51"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.postregister.com/chronicle/sports/grizzlies-outlast-broncos-in-hcc-slugfest/article_5cbf7829-f2cc-573c-bd42-8ed8787f5b51.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/chronicle/sports/grizzlies-outlast-broncos-in-hcc-slugfest/article_5cbf7829-f2cc-573c-bd42-8ed8787f5b51.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"5cbf7829-f2cc-573c-bd42-8ed8787f5b51"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.postregister.com/tncms/asset/editorial/5cbf7829-f2cc-573c-bd42-8ed8787f5b51" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"5cbf7829-f2cc-573c-bd42-8ed8787f5b51"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BPost%20Register%5D%20Grizzlies%20outlast%20Broncos%20in%20HCC%20slugfest&body=https%3A%2F%2Fwww.postregister.com%2Fchronicle%2Fsports%2Fgrizzlies-outlast-broncos-in-hcc-slugfest%2Farticle_5cbf7829-f2cc-573c-bd42-8ed8787f5b51.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"5cbf7829-f2cc-573c-bd42-8ed8787f5b51"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/chronicle/sports/grizzlies-outlast-broncos-in-hcc-slugfest/article_5cbf7829-f2cc-573c-bd42-8ed8787f5b51.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"5cbf7829-f2cc-573c-bd42-8ed8787f5b51"}'  rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-5cbf7829-f2cc-573c-bd42-8ed8787f5b51-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="5cbf7829-f2cc-573c-bd42-8ed8787f5b51" >
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="5cbf7829-f2cc-573c-bd42-8ed8787f5b51" class="save-list-5cbf7829-f2cc-573c-bd42-8ed8787f5b51-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="5cbf7829-f2cc-573c-bd42-8ed8787f5b51" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            
                        </div>
                        
                    </div></div><!-- /asset-content -->

                <div id="asset-below">
                    

                    

                    

                    

                    

                    
                        <div class="asset-tags hidden-print">
                            <h4>Tags</h4>
                            <ul class="list-inline"><li>
                <a href="/search/?k=%22team%22#tncms-source=keyword" class="tag-team label label-default" >Team</a>
            </li> <li>
                <a href="/search/?k=%22skyline%22#tncms-source=keyword" class="tag-skyline label label-default" >Skyline</a>
            </li> <li>
                <a href="/search/?k=%22sport%22#tncms-source=keyword" class="tag-sport label label-default" >Sport</a>
            </li> <li>
                <a href="/search/?k=%22baseball%22#tncms-source=keyword" class="tag-baseball label label-default" >Baseball</a>
            </li> <li>
                <a href="/search/?k=%22lead%22#tncms-source=keyword" class="tag-lead label label-default" >Lead</a>
            </li> <li>
                <a href="/search/?k=%22blackfoot%22#tncms-source=keyword" class="tag-blackfoot label label-default" >Blackfoot</a>
            </li> <li>
                <a href="/search/?k=%22dax%20whitney%22#tncms-source=keyword" class="tag-dax-whitney label label-default" >Dax Whitney</a>
            </li> <li>
                <a href="/search/?k=%22standing%22#tncms-source=keyword" class="tag-standing label label-default" >Standing</a>
            </li> <li>
                <a href="/search/?k=%22staff%22#tncms-source=keyword" class="tag-staff label label-default" >Staff</a>
            </li> </ul>
                        </div>
                    

                    

                    

                    

                    

                    

                    

                    

                    <div id="tncms-region-article_bottom" class="tncms-region hidden-print"></div>

                    <div class="asset-comments hidden-print">
                <div id="comments-container" class="comments-container">
                    
                    <div id="comments">
                        <div id="twt-comments"></div>
                        
                    </div>
                </div>
            
        </div>
                    
                    <div id="tncms-region-article_container_bottom" class="tncms-region hidden-print"></div><template class="hidden" id="infinity-asset-top">  
            <div id="tncms-region-infinity_asset_top" class="tncms-region "></div>
        </template>
        <template class="hidden" id="infinity-asset-after-first">
            <div id="tncms-region-infinity_asset_after_first" class="tncms-region "></div>
        </template>
        <template class="hidden" id="infinity-asset-after-third">
            <div id="tncms-region-infinity_asset_after_third" class="tncms-region "></div>
        </template>
        <template class="hidden" id="infinity-asset-after-fifth">
            <div id="tncms-region-infinity_asset_after_fifth" class="tncms-region "></div>
        </template>
        <template class="hidden" id="infinity-asset-after-eighth">
            <div id="tncms-region-infinity_asset_after_eighth" class="tncms-region "></div>
        </template>

    <div id="infinite-container" class="infinity-summary-container hidden-print">
        <div id="infinite-more" data-next-url="https://www.postregister.com/tncms/search/mlt/?origin=5cbf7829-f2cc-573c-bd42-8ed8787f5b51&app=editorial&inline=infinity&type=article%2Ccollection%2Cvideo%2Cyoutube">
            <i class="fas tnt-spinner tnt-pulse"></i>
        </div>
    </div>

    <script>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</script>
    </div>
            </div>

            

            </div>
        </div><div class="main-sidebar col-lg-4 col-md-5 hidden-print">
                <div class="main-sidebar-wrap">
                    <div id="tncms-region-article_side_top" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-top" class="tncms-region "></div><div id="tncms-region-asset_side_top" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-primary" class="tncms-region "><div id="tncms-block-1934520" class="tncms-block margin-bottom padding-bottom"><section id="block-1934520" class="block emphasis-h3   " ><div class="block"><a href="https://www.iccu.com/" rel="nofollow noopener" target="_blank">
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.chicago2.vip.townnews.com/postregister.com/content/tncms/custom/image/0872cab8-9c73-11eb-af0e-c391bffa7439.jpg?resize=150%2C125 150w, https://bloximages.chicago2.vip.townnews.com/postregister.com/content/tncms/custom/image/0872cab8-9c73-11eb-af0e-c391bffa7439.jpg?resize=200%2C167 200w, https://bloximages.chicago2.vip.townnews.com/postregister.com/content/tncms/custom/image/0872cab8-9c73-11eb-af0e-c391bffa7439.jpg?resize=225%2C188 225w, https://bloximages.chicago2.vip.townnews.com/postregister.com/content/tncms/custom/image/0872cab8-9c73-11eb-af0e-c391bffa7439.jpg 300w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                width="300"
                height="250"
                alt="Idaho Central Credit Union"></a></div></section></div><div id="tncms-block-1609233" class="tncms-block hidden-sm hidden-xs"><div class="tnt-ads-container text-center  " >
        <div id="ad-1609233" class="tnt-ads dfp-ad" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-1609233');
                        
                });
            </script>
        </div>
    </div>
</div><div id="tncms-block-1609237" class="tncms-block hidden-lg hidden-md"><div class="tnt-ads-container text-center  " >
        <div id="ad-1609237" class="tnt-ads dfp-ad" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-1609237');
                        
                });
            </script>
        </div>
    </div>
</div><div id="tncms-block-1910903" class="tncms-block"><div id="evvnt-calendar"></div>
<script async defer src="//production-evvnt-plugin-herokuapp-com.global.ssl.fastly.net/evvnt_discovery_plugin_s.js" onload="evvntDiscoveryInit();">
</script><script>
  function evvntDiscoveryInit() {
    evvnt_require("evvnt/discovery_plugin").init({
      api_key: "POSTREGISTERN",
      publisher_id:8950,
      discovery: {
        element: "#evvnt-calendar",
        detail_page_enabled: true,
        widget: true,
        virtual: false,
        map: false,
        category_id: null,
        orientation: "vertical",
        number: 3,
      },
      submission: {
        partner_name: "Bingham News Chronicle",
        text: "Promote your event",
      }
   });
 }
</script></div><div id="tncms-block-1600885" class="tncms-block ad-spacer-bottom"><section id="block-1600885" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1600885 ">
        <div class="block-title-inner">
            <h4>
                
                News Trending Today
                
            </h4>
        </div>
    </div></div>
        <div class="card-panel panel">
            <div class="panel-body">
    
    <div class="card">
        <ul class="list-unstyled list-popular bold"><li>
                    
                        <h5 class="tnt-headline ">
        
             <a href="/news/government/ehardt-bill-latest-to-address-education-concerns/article_b1dbd936-ee37-5e85-a302-4c0953b2552d.html" class="tnt-asset-link">
        

        
            Ehardt bill latest to address education concerns</a></h5>
                    
                </li><li>
                    
                        <h5 class="tnt-headline ">
        
             <a href="/chronicle/news/blackfoot-makes-offer-on-former-nonpariel-administration-building/article_7c221e59-b419-5b89-bef9-5cb2d66d090b.html" class="tnt-asset-link">
        

        
            Blackfoot makes offer on former Nonpariel Administration building</a></h5>
                    
                </li><li>
                    
                        <h5 class="tnt-headline ">
        
             <a href="/opinion/letters_to_editor/opinion-the-biggest-snowflake-nomination/article_fa7452f8-a791-5a62-bfc0-8a9a4ebe6d57.html" class="tnt-asset-link">
        

        
            Opinion: The biggest snowflake nomination</a></h5>
                    
                </li><li>
                    
                        <h5 class="tnt-headline ">
        
             <a href="/news/education/cei-trustees-take-first-look-at-future-tech-building/article_e7b05965-052a-5158-870a-1572f20b7173.html" class="tnt-asset-link">
        

        
            CEI trustees take first look at Future Tech building</a></h5>
                    
                </li><li>
                    
                        <h5 class="tnt-headline ">
        
             <a href="/news/crime_courts/jefferson-county-man-arrested-admits-to-planting-cameras-in-bathroom/article_d3e70c06-54ce-5e66-bfd8-971cca625ab8.html" class="tnt-asset-link">
        

        
            Jefferson County man arrested, admits to planting cameras in bathroom</a></h5>
                    
                </li><li>
                    
                        <h5 class="tnt-headline ">
        
             <a href="/news/local/amid-race-theory-concerns-house-kills-budget-for-idahos-teachers/article_1f7a1df1-42fb-586a-8cd9-9bebcbfd32ef.html" class="tnt-asset-link">
        

        
            Amid 'race theory' concerns, House kills budget for Idaho's teachers</a></h5>
                    
                </li><li>
                    
                        <h5 class="tnt-headline ">
        
             <a href="/farmandranch/idaho/idaho-lawmakers-hear-pitch-to-absorb-three-fourths-of-oregon/article_f9cb5f09-6598-5075-a36f-7a7afd27d31e.html" class="tnt-asset-link">
        

        
            Idaho lawmakers hear pitch to absorb three-fourths of Oregon</a></h5>
                    
                </li><li>
                    
                        <h5 class="tnt-headline ">
        
             <a href="/coronavirus/eastern-idaho-doctors-cautiously-grateful-for-regions-low-virus-counts/article_3ee3f3e6-755a-519a-af6a-46f8d1fe3bd7.html" class="tnt-asset-link">
        

        
            Eastern Idaho doctors cautiously grateful for region's low virus counts</a></h5>
                    
                </li><li>
                    
                        <h5 class="tnt-headline ">
        
             <a href="/postregister/high-school-roundup-skyline-baseball-erases-late-deficit-to-beat-blackfoot/article_456d43bb-10ff-596b-b281-004b9af5ad18.html" class="tnt-asset-link">
        

        
            HIGH SCHOOL ROUNDUP: Skyline baseball erases late deficit to beat Blackfoot</a></h5>
                    
                </li><li>
                    
                        <h5 class="tnt-headline ">
        
             <a href="/milestones/obituaries/burton-louise/article_12f56438-2d98-543a-a2c7-86ca3be14503.html" class="tnt-asset-link">
        

        
            Burton, Louise</a></h5>
                    
                </li></ul>
    </div>
    
            </div>
        </div>
    
</section></div><div id="tncms-block-1646372" class="tncms-block margin-bottom padding-bottom"><section id="block-1646372" class="block emphasis-h3   " ><div class="block"><a href="https://www.postregister.com/blogs/capitol_letters/" rel="nofollow" >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.chicago2.vip.townnews.com/postregister.com/content/tncms/custom/image/45302502-1464-11e9-b66f-db2b75863f79.png?resize=150%2C72 150w, https://bloximages.chicago2.vip.townnews.com/postregister.com/content/tncms/custom/image/45302502-1464-11e9-b66f-db2b75863f79.png?resize=200%2C96 200w, https://bloximages.chicago2.vip.townnews.com/postregister.com/content/tncms/custom/image/45302502-1464-11e9-b66f-db2b75863f79.png?resize=225%2C108 225w, https://bloximages.chicago2.vip.townnews.com/postregister.com/content/tncms/custom/image/45302502-1464-11e9-b66f-db2b75863f79.png?resize=300%2C144 300w, https://bloximages.chicago2.vip.townnews.com/postregister.com/content/tncms/custom/image/45302502-1464-11e9-b66f-db2b75863f79.png 400w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                width="360"
                height="173"
                alt=""></a></div></section></div><div id="tncms-block-1643973" class="tncms-block"><script src="https://embed.secondstreetapp.com/Scripts/dist/optin.js" data-ss-embed="optin" data-design-id="284247"></script></div><div id="tncms-block-1609236" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-1609236" class="tnt-ads dfp-ad" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-1609236');
                        
                });
            </script>
        </div>
    </div>
</div></div><div id="tncms-region-global-side-middle" class="tncms-region "></div><div id="tncms-region-asset_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-article_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-secondary" class="tncms-region hidden-print"><div id="tncms-block-1660378" class="tncms-block"></div><div id="tncms-block-1601000" class="tncms-block"><style>
    #lighterside {
        position: relative;
        z-index: 0;
        width: 100%;
        padding: 6px;
        background-color: #222222;
        margin-bottom: 30px;
    }
    #lighterside .ls-bg {
        position: absolute;
        z-index: 1;
        top: 75px; left: 6px; right: 6px; bottom: 6px;
        background-color: #ffffff;
        background-position: center;
        background-repeat: no-repeat;
        background-size: cover;
    }
    #lighterside .ls-banner {
        position: relative;
        z-index: 2;
        display: block;
        height: 69px;
        background-position: center;
        background-repeat: no-repeat;
        background-size: contain;
        margin-bottom: 6px;
    }
    #lighterside .ls-link {
        position: relative;
        z-index: 2;
        display: inline-block;
        width: 50%;
        height: 75px;
        vertical-align: top;
        background-position: center;
        background-repeat: no-repeat;
        background-size: contain;
    }
</style>
<div id="lighterside">
    <div class="ls-bg" style="background-image:url(https://bloximages.chicago2.vip.townnews.com/postregister.com/content/tncms/live/libraries/flex/components/site/resources/images/lighterside/lighterside-bg.png?_dc=1531426836);"></div>
    <a href="http://bradysbunch.com" class="ls-banner" target="_blank" title="Lighter Side: Powered By Brady's" style="background-image:url(https://bloximages.chicago2.vip.townnews.com/postregister.com/content/tncms/live/libraries/flex/components/site/resources/images/lighterside/brady-banner.png?_dc=1531426773);"></a>
    <a href="http://www.uexpress.com/go-comics" class="ls-link" target="_blank" title="Comics" style="background-image:url(https://bloximages.chicago2.vip.townnews.com/postregister.com/content/tncms/live/libraries/flex/components/site/resources/images/lighterside/comics.png?_dc=1531429413);"></a><a href="http://www.uexpress.com/puzzle-society?amu=/iwin-sudoku" class="ls-link" target="_blank" title="Sudoku" style="background-image:url(https://bloximages.chicago2.vip.townnews.com/postregister.com/content/tncms/live/libraries/flex/components/site/resources/images/lighterside/sudoku.png?_dc=1531429455);"></a>
    <a href="http://www.gocomics.com/comics/a-to-z" class="ls-link" target="_blank" title="More Comics" style="background-image:url(https://bloximages.chicago2.vip.townnews.com/postregister.com/content/tncms/live/libraries/flex/components/site/resources/images/lighterside/more-comics.png?_dc=1531429445);"></a><a href="http://www.uexpress.com/puzzle-society?amu=/iwin-jumble" class="ls-link" target="_blank" title="Jumble" style="background-image:url(https://bloximages.chicago2.vip.townnews.com/postregister.com/content/tncms/live/libraries/flex/components/site/resources/images/lighterside/jumble.png?_dc=1531429434);"></a>
    <a href="http://www.uexpress.com/puzzle-society?amu=/iwin-crossword" class="ls-link" target="_blank" title="Crosswords" style="background-image:url(https://bloximages.chicago2.vip.townnews.com/postregister.com/content/tncms/live/libraries/flex/components/site/resources/images/lighterside/crosswords.png?_dc=1531429423);"></a><a href="http://www.uexpress.com/astro-graph" class="ls-link" target="_blank" title="Astro-Graph" style="background-image:url(https://bloximages.chicago2.vip.townnews.com/postregister.com/content/tncms/live/libraries/flex/components/site/resources/images/lighterside/astro-graph.png?_dc=1531429400);"></a>
    <a href="https://www.washingtonpost.com/lifestyle/advice/ask-amy" class="ls-link" target="_blank" title="Ask Amy" style="background-image:url(https://bloximages.chicago2.vip.townnews.com/postregister.com/content/tncms/live/libraries/flex/components/site/resources/images/lighterside/ask-amy.png?_dc=1531429390);"></a><a href="https://www.washingtonpost.com/lifestyle/advice/?utm_term=.3d9cb71f53c6" class="ls-link" target="_blank" title="Advice" style="background-image:url(https://bloximages.chicago2.vip.townnews.com/postregister.com/content/tncms/live/libraries/flex/components/site/resources/images/lighterside/advice.png?_dc=1531429380);"></a>
</div></div></div><div id="tncms-region-global-side-bottom" class="tncms-region "><div id="tncms-block-1609235" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-1609235" class="tnt-ads dfp-ad" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-1609235');
                        
                });
            </script>
        </div>
    </div>
</div></div><div id="tncms-region-asset_side_bottom" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-tertiary" class="tncms-region "><div id="tncms-block-1590508" class="tncms-block"><div id="ap_widget_container_564a9baae69e7fc30b04e365f68add37"></div><script src="https://digitalservices.ap.org/widget-content/564a9baae69e7fc30b04e365f68add37"></script></div><div id="tncms-block-1590510" class="tncms-block"><div id="ap_widget_container_7640acc85af051f21352d1318d29a562"></div><script src="https://digitalservices.ap.org/widget-content/7640acc85af051f21352d1318d29a562"></script></div></div><div id="tncms-region-article_side_bottom" class="tncms-region hidden-print"></div>
                <div id="sticky-right-rail-spacer">
                    <div id="sticky-right-rail"><div id="tncms-region-global-side-sticky" class="tncms-region hidden-print"></div><div id="tncms-region-asset_side_sticky" class="tncms-region hidden-print"></div></div>
                </div>
                </div>
            </div></div>
</article>
<div class="row">
            <div class="col-md-12"><div id="tncms-region-global-container-bottom" class="tncms-region "><div id="tncms-block-1609238" class="tncms-block hidden-sm hidden-xs"><div class="tnt-ads-container text-center  " >
        <div id="ad-1609238" class="tnt-ads dfp-ad" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-1609238');
                        
                });
            </script>
        </div>
    </div>
</div><div id="tncms-block-1609240" class="tncms-block hidden-lg hidden-md"><div class="tnt-ads-container text-center  " >
        <div id="ad-1609240" class="tnt-ads dfp-ad" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-1609240');
                        
                });
            </script>
        </div>
    </div>
</div></div></div>
        </div></section>
    <section id="main-bottom-container" class="container-fullscreen-region container-fluid">
        <div class="fullscreen-region"><div id="tncms-region-global-container-bottom-fullscreen" class="tncms-region "></div></div>
    </section><!-- / main-body-container -->
    </div>
    <div id="site-footer-container" class="hidden-print">
         
            <div class="container">
                <div id="asset-container-bottom" class="col-md-12">
                    <div id="tncms-region-asset_container_bottom" class="tncms-region hidden-print"></div> 
                </div>
            </div>
        

        
            <footer id="site-footer" class="container well-main">
                
                <div id="tncms-region-footer-top-col-full" class="tncms-region "><div id="tncms-block-1590515" class="tncms-block"><div class="footerContainer-1590515 footerContainer footer-upper hidden-sm">
        <div class="cols-wrap">
            <ul class="footer-col footer-col-list col-md-3 col-sm-6 col-xs-12">
                <li class="col-heading"><a href="/" style="color:#fff;">News</a></li>
                <li class="col-item"><a href="/" title="Post Register">Post Register</a></li><li class="col-item"><a href="/messenger" title="Challis Messenger">Challis Messenger</a></li><li class="col-item"><a href="/star" title="Jefferson Star">Jefferson Star</a></li><li class="col-item"><a href="/chronicle" title="Bingham County">Bingham County</a></li><li class="col-item"><a href="/preps" title="PR Preps">PR Preps</a></li><li class="col-item"><a href="https://www.idahostatejournal.com/business_journal" target="_blank" title="Business Journal">Business Journal</a></li><li class="col-item"><a href="/farmandranch" title="Farm & Ranch">Farm & Ranch</a></li><li class="col-item"><a href="https://www.idahopress.com/eyeonboise/" target="_blank" title="Eye On Boise">Eye On Boise</a></li><li class="col-item"><a href="/eedition/" target="" title="E-Edition">E-Edition</a></li><li class="col-item"><a href="/classifieds/" target="" title="Classifieds">Classifieds</a></li><li class="col-item"><a href="https://www.legacy.com/obituaries/postregister/" target="" title="Obituaries">Obituaries</a></li><li class="col-item"><a href="/subscribe" target="_blank" title="Subscribe Today">Subscribe Today</a></li></ul>
            <ul class="footer-col footer-col-list col-md-3 col-sm-6 col-xs-12">
                <li class="col-heading"><a href="/site/services/" style="color:#fff;">Services</a></li><li class="col-item"><a href="/site/services/" target="" title="Subscriber Services">Subscriber Services</a></li><li class="col-item"><a href="/site/advertise/" target="" title="Advertising Services">Advertising Services</a></li><li class="col-item"><a href="/site/printing/" target="" title="Printing Services">Printing Services</a></li><li class="col-item"><a href="/site/archives/" target="" title="Search the Archives">Search the Archives</a></li><li class="col-item"><a href="mailto:newsroom@postregister.com" target="" title="Email Newsroom">Email Newsroom</a></li><li class="col-item"><a href="mailto:classifieds@postregister.com" target="" title="Email Classified">Email Classified</a></li><li class="col-item"><a href="/managesubscription" target="_blank" title="Manage Your Subscription">Manage Your Subscription</a></li><li class="col-item"><a href="/managesubscription" target="_blank" title="Pay Subscription Bill">Pay Subscription Bill</a></li><li class="col-item"><a href="https://classadz.vdata.com/IdahoFallsPostRegister/Advertising/Advertiser" target="_blank" title="Place a Classified Ad">Place a Classified Ad</a></li><li class="col-item"><a href="https://portal.cityspark.com/EventEntry/EventEntry/PostRegister" target="" title="Add a Calendar Event">Add a Calendar Event</a></li></ul>
            <ul class="footer-col footer-col-list col-md-3 col-sm-6 col-xs-12">
                <li class="col-heading">Submissions</li><li class="col-item"><a href="/site/forms/chronicle/chronicle_news" target="" title="Submit News Tip">Submit News Tip</a></li><li class="col-item"><a href="/site/forms/chronicle/chronicle_letter" target="" title="Letter to the Editor">Letter to the Editor</a></li><li class="col-item"><a href="/site/forms/chronicle/chronicle_anniversary" target="" title="Anniversary Announcement">Anniversary Announcement</a></li><li class="col-item"><a href="/site/forms/chronicle/chronicle_birthday" target="" title="Birthday Announcement ">Birthday Announcement </a></li><li class="col-item"><a href="/site/forms/chronicle/chronicle_birth" target="" title="Birth Announcement">Birth Announcement</a></li><li class="col-item"><a href="/site/forms/chronicle/chronicle_wedding" target="" title="Wedding Announcement">Wedding Announcement</a></li><li class="col-item"><a href="/site/forms/chronicle/chronicle_missionary" target="" title="Missionary Announcement">Missionary Announcement</a></li></ul>
            <div class="footer-col footer-col-info col-md-3 col-sm-6 col-xs-12">
                <div class="footer-col-info-basic">
                    <div class="col-heading"><a href="/site/contact/" style="color:#fff;">Contact Us</a></div>
                    
                    <div class="col-item col-item-highlight">Bingham News Chronicle</div>
                    <div class="col-item"><a href="http://maps.google.com/maps?daddr=34+N.+Ash+Blackfoot,+Idaho+83221" target="_blank">34 N. Ash<br>Blackfoot, Idaho 83221</a></div>
                    <div class="col-item"><a href="tel:2086838169">208-683-8169</a></div>
                    <div class="col-item"><a href="mailto:bccnews@bcchron.com">bccnews@bcchron.com</a></div><li class="col-item"><a href="/site/about/" target="" title="About Us">About Us</a></li><li class="col-item"><a href="/site/contact/" target="" title="Contact Us">Contact Us</a></li><li class="col-item"><a href="/site/staff/" target="" title="Our Staff">Our Staff</a></li></div>
                <div class="footer-col-info-social">
                    <div class="col-heading">Follow Us</div><div class="col-item-icon"><a href="https://www.facebook.com/BinghamNewsChronicle" target="_blank" title="Facebook"><span class="fab tnt-facebook-f"></span></a></div></div>
            </div>
            <div style="clear:both;"></div>
        </div>
    </div></div></div>
                <div class="row">
                    <div id="footer-col-one" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-one" class="tncms-region "></div></div>
    <div id="footer-col-two" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-two" class="tncms-region "></div></div>
    <div id="footer-col-three" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-three" class="tncms-region "></div></div>
                </div>
                <div id="tncms-region-footer-bottom-col-full" class="tncms-region "></div>
                
<script>
/**
* Function that tracks a click on an outbound link in Google Analytics.
* This function takes a valid URL string as an argument, and uses that URL string
* as the event label.
*/
var trackOutboundLink = function(url) {
   ga('send', 'event', 'outbound', 'click', url, {'hitCallback':
     function () {
     document.location = url;
     }
   });
}
</script>

            </footer>
        

        <div id="site-copyright-container" class="container">
            <div id="tncms-region-footer-copyright" class="tncms-region "><div id="tncms-block-1696181" class="tncms-block"><style>
	#tncms-block-1696181 {
		display: none;
		position: fixed;
		bottom: 0;
		z-index: 300;
		left: 50%;
		-webkit-transform: translateX(-50%);
		   -moz-transform: translateX(-50%);
			-ms-transform: translateX(-50%);
				transform: translateX(-50%);
		width: 100%;
		max-width: 900px;
	}
	#block-1696181 .block-title  {
		display: none;
	}
	.clearFix {
		clear: both;
	}
	.fop_promo {

	}
	.fop_heading {
		background-color: #2d4fad;
		color: #ffffff;
		padding: 12px 24px;
		font-size: 16px;
		line-height: 24px;
		position: relative;
	}
	.fop_offerShort {
		float: left;
		padding-right: 24px;
	}
	.fop_login {
		float: right;
		padding-right: 36px;
		font-size: 14px;
	}
	.fop_login a {
		color: #ffffff;
		text-decoration: none;
	}
	.fop_login a:hover {
		color: #ffffff;
		text-decoration: underline;
	}
	.fop_close {
		position: absolute;
		top: 12px;
		right: 12px;
		width: 24px;
		height: 24px;
		text-align: center;
		font-size: 16px;
		cursor: pointer;
	}
	.fop_body {
		background-color: #f0f0f0;
		color: #222222;
		border-left: 1px solid rgba(0,0,0,0.25);
		border-right: 1px solid rgba(0,0,0,0.25);
		max-height: 0;
		-webkit-transition: all 300ms ease;
		transition: all 300ms ease;
	}
	#block-1696181:hover .fop_body {
		max-height: 1000px;
		border-bottom: 1px solid rgba(0,0,0,0.25);
	}
	.fop_body > div {
		display: inline-block;
		width: 33.333%;
		vertical-align: middle;
		padding: 24px 24px;
	}
	.fop_logo {
		text-align: center;
	}
	.fop_logo img {
		margin: 0 auto;
	}
	.fop_tagline {
		text-align: center;
		font-size: 16px;
		line-height: 24px;
	}
	.fop_offerLong {
		text-align: center;
	}
	.fop_offerLong .fop_offerText {
		text-align: left;
		margin-bottom: 12px;
	}
	.fop_offerLong .fop_offerLink {
		margin: 0 auto;
		border: 1px solid #2d4fad;
		background-color: #2d4fad;
		color: #ffffff;
		display:inline-block;
		padding:6px 15px;
		cursor: pointer;
		-webkit-transition: all 200ms ease;
		transition: all 200ms ease;
	}
	.fop_offerLink:hover {
		background-color: #ffffff;
		color: #2d4fad;
		display:inline-block;
		padding:6px 15px;
		text-decoration: none;
	}
	.fop_offerLink:hover a {
		text-decoration: none;
	}
	@media screen and (max-width: 750px) {
		.fop_body > div {
			width: 100%;
			padding: 12px 24px;
		}
		.fop_body {
			padding: 0px 0px;
		}
		#block-1696181:hover .fop_body {
			padding: 12px 0px;
		}
		.fop_offerLong .fop_offerText {
			text-align: center;
		}
	}
</style>
<script>
(function($) {
$(function() {
	var thisBlock = $('#tncms-block-1696181');
	var thisBlockClose = $('#tncms-block-1696181 .fop_close');
	var urSet = $.cookie('tncms-services');
	var fopNo = $.cookie('fop_no');
	// user closed promo
	thisBlockClose.click(function(){
		thisBlock.css('display','none');
		$.cookie('fop_no', 1, { path: '/', expires: 7 });
	});
	// user is logged in or has previously closed promo
	if( ( urSet && urSet != '' ) || ( fopNo && fopNo != '' ) ) {
		thisBlock.css('display','none');
	} else {
		thisBlock.css('display','block');
	}
})
})(jQuery);
</script><section id="block-1696181" class="block emphasis- #222222 heading-color  " ><div class="clearfix">
    
    <div class="block-title title-1696181 #ffffff">
        <div class="block-title-inner">
            <h2>
                
                Footer Offer Promo
                
            </h2>
        </div>
    </div></div><div class="fop_promo invalid-subscribers-only">
	<div class="fop_heading">
		<div class="fop_offerShort">CARRIERS NEEDED!</div>
		
                <div class="fop_close"><i class="fas tnt-times" aria-hidden="true"></i></div>
		<div class="clearFix"></div>
	</div>
	<div class="fop_body">
		<div class="fop_logo"><img class="media-object img-responsive " src="https://bloximages.chicago2.vip.townnews.com/postregister.com/content/tncms/custom/image/9b041326-b93c-11e9-b540-e773ed0ee3f5.png" alt=""></div><div class="fop_tagline">Local News Worth Delivering
		</div><div class="fop_offerLong">
			<div class="fop_offerText">Become a newspaper carrier for the Post Register and earn extra income!</div>
			<a href="/carrier/" class="fop_offerLink">Apply Today!</a>
		</div>
	</div>
</div></section></div><div id="tncms-block-1589774" class="tncms-block"><div id="site-copyright" class="row">
    <section id="block-1589774"><div class="col-md-7"><small>&copy; Copyright 2021 <a href="/">Post Register</a>, 333 Northgate Mile Idaho Falls, ID</small><small>&nbsp;| <a href="/site/terms.html">Terms of Use</a></small><small>&nbsp;| <a href="/site/privacy.html">Privacy Policy</a></small></div>
        <div class="col-md-5"><small>Powered by <a href="https://bloxcms.com" title="BLOX Content Management System" target="_blank" rel="noopener">BLOX Content Management System</a> from <a href="https://townnews.com/" title="TownNews.com BLOX Newspaper Content Management" target="_blank" rel="noopener">TownNews.com</a>.</small></div>
    </section>
</div></div></div>
        </div>
    </div>
    
    
        </div><!-- / offcanvas close  -->
    

    
    
    <!-- / site-container close -->
    </div>
    
    
    <script>
        window.__tnt = window.__tnt || {};
        __tnt.compatibility = __tnt.compatibility || {};

        __tnt.compatibility.status = '';
        __tnt.compatibility.check = function() {
            if (typeof __tnt.advertisements == 'undefined') {
                __tnt.compatibility.status = 'FAIL: object 0 undefined';
                return false;
            }
            return true;
        };
        __tnt.compatibility.notification = function() {
            if (!document.getElementById('notification-area')) {
                    var el = document.createElement('div');
                    el.id = 'notification-area';
                    document.querySelector('#asset-content .asset-body').appendChild(el);
                }
                __tnt.template(
                    document.getElementById('template-blox-message-incompatible'),
                    document.getElementById('notification-area'),
                    true,
                    [],
                    function(el) {
                        setTimeout(function() {
                            var message = document.getElementById('blox-message-incompatible');
                            var authStatusCls = (__tnt.user.authToken) ? 'logged-in' : 'not-logged-in';
                                Array.from(message.getElementsByClassName(authStatusCls)).forEach(function(el) {
                                    el.style.display = 'block';
                                });
                            
                            if (__tnt.user.services) {
                                message.parentNode.removeChild(message);
                            } else {
                                message.style.display = 'block';
                                }
                        }, 100);
                    }
                );
            };
        (function() {
            function compatibilityCheck() {
                if (!__tnt.compatibility.check()) {
                    __tnt.trackEvent({
                        'category':'subscription',
                        'action':'adblock',
                        'label':'adblock detected',
                        'value':'1'
                    });
                    __tnt.compatibility.notification();
                }
            }

            if (document.readyState != 'loading') {
                compatibilityCheck();
            } else {
                document.addEventListener('DOMContentLoaded', compatibilityCheck);
            }
        })();
    </script>
    <template id="template-blox-message-incompatible">
            </template>
    
    
    <script>
        jQuery(function() {
            if(typeof TNCMS.Tracking != 'undefined'){
                jQuery(TNCMS.Tracking.trackDeclarativeEvents);
            }dataLayer.push({'tncms.client.recent_five':__tnt.recentFive.add("5cbf7829-f2cc-573c-bd42-8ed8787f5b51")});});
    </script>

    <script>
        __tnt.trackEvent = function(obj) {
            if (typeof obj === 'object') {
                    if (obj.category && obj.action) {
                        __tnt.googleEvent(obj);
                    } else if (obj.network && obj.socialAction) {
                        __tnt.googleSocial(obj);
                    } else if (obj.url) {
                        __tnt.googlePageView(obj);
                    }
                    if (typeof TNCMS.Tracking != 'undefined' && obj.metric) {
                        TNCMS.Tracking.addEvent({
                            app: obj.app,
                            metric: obj.metric,
                            id: obj.uuid
                        });
                    }
            }
        };

        if (__tnt.trackEventLater.length > 0) {
            __tnt.trackEventLater.forEach(function(obj) {
                __tnt.trackEvent(obj);
            });
        }

        Array.from(document.querySelectorAll('body [data-track]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.track));
            });
        });
        Array.from(document.querySelectorAll('body [data-tncms-track-event]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.tncmsTrackEvent));
            });
        });
        
        Array.from(document.querySelectorAll('body [data-tncms-track-dmp]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                var dmpData = el.dataset.tncmsTrackDmp;
                
            });
        });
    
    </script>
    
    
<script src="https://bloximages.chicago2.vip.townnews.com/postregister.com/content/tncms/live/libraries/flex/components/site/resources/scripts/main.js?_dc=1529519169"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/postregister.com/content/tncms/live/libraries/flex/components/site/resources/scripts/jquery.matchHeight.js?_dc=1529519155"></script>
<script>/*<![CDATA[*/ 
                __tnt.googleEvent = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.trigger',
                             'tncms.event.trigger.category': obj.category,
                             'tncms.event.trigger.action': obj.action,
                             'tncms.event.trigger.label': obj.label, 
                             'tncms.event.trigger.value': obj.value
                    });
                }
                /* Virtual page view */
                __tnt.googlePageView = function(obj) {
                    var sURL = obj.url.replace(/^.*\/\/[^\/]+/, '');
                    dataLayer.push({
                        'event': 'tncms.event.virtual_pageview',
                            'tncms.event.virtual_pageview.url': sURL,
                            'tncms.event.virtual_pageview.title': obj.title
                    });
                }
                /* Social event */
                __tnt.googleSocial = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.social',
                            'tncms.event.social.network': obj.network,
                            'tncms.event.social.action': obj.socialAction,
                            'tncms.event.social.target': obj.url
                    });
                } /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/postregister.com/shared-content/art/tncms/templates/libraries/flex/components/metering/resources/scripts/tnt.metering.c1fd4b9015c14b57a58acdbc3ee4daca.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/postregister.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/asset-edit.60e8e67e04be1194326dcfbe7f00b8c3.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/postregister.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/scripts/promo_popup.fe40d77fce691e6ed54cb520a782a693.js"></script>
<script>/*<![CDATA[*/ 
            // Observer callback
            var callback = function(entries, io) {
                entries.forEach(function(e) {
                    if (e.isIntersecting === true) {
                        __tnt.template(
                            document.querySelector('#' + e.target.id + ' template'),
                            document.getElementById(e.target.id),
                            false,
                            objectFitImages('#' + e.target.id + ' img') // IE11 objectfit polyfill
                        );
                        // Kill observer
                        io.unobserve(e.target);
                    }
                });
            };
            // Initialize observer
            window.addEventListener('load', function() {
                var io = new IntersectionObserver(callback),
                    targets = Array.from(document.querySelectorAll('[data-lazy-content]')); // IE11 forEach support
                targets.forEach(function(e){
                    io.observe(e);
                });
            }, false) /*]]>*/</script></body>
</html>